Problems without monitor

Forums / NoMachine for Linux / Problems without monitor

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #10232
    Avatarsg4rb0
    Participant

    I have a Ubuntu server with a monitor attached to it. I am using an Ubuntu client machine, also with a monitor, to connect to it.

    I can NoMachine onto the server just fine. But if I reboot the server, NoMachine won’t allow me to connect to it once it’s rebooted. The way I fixed this was by first ssh’ing to my server, and then I can NoMachine onto it.

    Which leads me to my next problem. If I pull the monitor out of the server (I want to just dump my computer in another room without a monitor attached), then this little trick I’ve got going (to first ssh to the server and then NoMachine onto it) doesn’t work anymore. What happens is I can ssh and login to the server. Then when I NoMachine onto it, I can connect and see the screen (which at this point, is the initial login screen that appears when you normally boot the server). However, once I log in, I can’t click on anything. Why?

    #10249
    Avatarsg4rb0
    Participant

    I have an update for this. I changed the graphics card driver on the server for testing. So I then unplugged the monitor, booted the server up, ssh’d to it and logged in. Then I try to NoMachine to it, and I get the error below:

    “Cannot detect any display running. Do you want NoMachine to create a new display and proceed to connect to the desktop?”

    If I say “yes”, the screen goes black. If I say “no”, it doesn’t connect. Can you also tell me why I always have to ssh to the box and login first before I can even get nomachine to authenticate?

    #10255
    Avatarkroy
    Contributor

    Can you also tell me why I always have to ssh to the box and login first before I can even get NoMachine to authenticate?

    Our developers are investigating this problem.

    Message “Cannot detect any display running. Do you want NoMachine to create a new display and proceed to connect to the desktop?” shows when there is no started X server on the host. Are you sure that you can see the desktop if you plug-in the monitor after changing the GFX driver? If you can see the correct display on the screen, please run debug in NoMachine, reproduce problem and send logs from server and client side to forum[at]nomachine[dot]com? You can find instructions about collecting logs here: https://www.nomachine.com/DT04M00076.
    Please also send .xsession-errors file, which you can find in the home directory.

    #10306
    Avatarsg4rb0
    Participant

    Hi, yes I’m 100% sure that if I plug the monitor in on the server machine (that I am trying to NoMachine onto), the functionality works fine (providing I have ssh’d to the device first: such a bad design to make people do this).

    As for reproducing this problem, I won’t be able to anymore. I’ve decided to remove Ubuntu and install Arch on my client machine. I am guessing I will still run into the same issues though when I come to install and test it in the next few days.

    #10319
    Avatarkroy
    Contributor

    Let us know whether you are getting the same issue on Arch. I must add that this behavior of having to ssh in beforehand is not normal with NoMachine, and since we can’t reproduce it (not so far anyway), we would ideally need the debug logs.

    #10323
    Avatarsg4rb0
    Participant

    I will. I wonder if this has anything to do with my home drive being encrypted? I had an encrypted home drive on both PC’s during the problem. Maybe you can try doing that in your test lab?

    #10341
    AvatarBritgirl
    Keymaster

    Just for the record, you should use the instructions here if you are interested in sending us the debug logs (from both client and server)

    https://www.nomachine.com/DT07M00098

    #10324
    Avatarsg4rb0
    Participant

    FYI both machines were running Ubuntu 14.04 LTS, with the only modification that the Kernel was Linux 4.3.0-040300-generic, and the home drives were encrypted.

    #10358
    AvatarBritgirl
    Keymaster

    We’ve tried with the same kernel version, we can’t reproduce it. What I suggest is that when you’ve moved over to Arch and if you come up against the same problem, you submit the logs.

    #10364
    Avatarsg4rb0
    Participant

    OK. I will have it installed tomorrow. I just wanted to say thanks for your efforts. It’s very re-assuring to see your level of support on the product.

    #10379
    Avatarkroy
    Contributor

    I wonder if this has anything to do with my home drive being encrypted?

    It’s connected with your first problem – “Can you also tell me why I always have to ssh to the box and login first before I can even get NoMachine to authenticate?” It’s our bug. You can follow up that Trouble Report https://www.nomachine.com/TR02N06450 to know when it will be fixed. You could connect using SSH protocol, but that feature is disabled on the free version.

    About problem with unplugged monitor:

    Your Ubuntu is with Unity? Can you try other environment, for example xfce4? Can you tell us what graphic card you have? Logs would be really helpful to find problem.

Viewing 11 posts - 1 through 11 (of 11 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.