Public IP address not displayed

Forums / NoMachine for Linux / Public IP address not displayed

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #16908
    xprinceps
    Participant

    I am trying to access a Linux (Ubuntu) machine over the internet. When I launch NoMachine on the host, only the local IP address is displayed, and when I try to connect using the public IP address, I get “Could not connect to server. Error is 61: Connection refused.”

    I have looked at this thread (https://forums.nomachine.com/topic/nomachine-will-not-show-public-ip-address-on-both-windows-and-linux), which suggests following the directions here: https://www.nomachine.com/AR11L00827. The recommendations here seem to be open port 4000 on my router and map it to the public IP address and to edit the EnableUPnP line of the server.cfg file to “EnableUPnP NX”. The server.cfg file already says “EnableUPnP NX”, and I have no idea how to open ports on my router (if that’s really the problem). Any help would be appreciated.

    #16923
    irek
    Participant

    Hello xprinceps,

    according to https://www.nomachine.com/AR11L00827:

    “When the NoMachine (server) computer is behind a NAT router or a firewall, NoMachine tries to use the UPnP or NAT-PMP protocol (depending on what is supported by the router) to:

    – Retrieve the public or external IP of the host machine where it’s installed.

    – Configure the router to allow a NoMachine client to connect from outside of the private network.”
    First I would suggest to check if:

    – your router has enabled UPnP or NAT-PMP protocol, if not try to enable it and then restart the router.

    – Please check that UPnP is enabled on nxserver.

    Check the key ‘EnableUPnP’ in server.cfg if it is set to NX, if not set it and restart nxserver.
    Then please run a terminal and execute the commands:

    sudo /etc/NX/nxserver --upnpmap
    sudo /etc/NX/nxserver --upnpstatus

    If the router doesn’t support UPnP or NAT-PMP protocol or you still don’t see the ports you will have to configure port forwarding by using the router admin interface. This is normally a Web application running at http://192.168.1.1. Follow these instructions for your router:

    1. Reserve local IP of your computer on router according to your router’s instructions.
    2. Open a unique port for that local IP in Port Forwarding section on the router.
    3. Check public IP of the router.
    4. Now in your Player connection settings – enter the public IP of your router and unique port. Now you should connect to your machine.

    Please see ‘IMPORTANT’ section from https://www.nomachine.com/AR11L00827 .

    Could you also provide to us router name and model, you can usually find it on a sticker on the bottom or back of the router?

    • This reply was modified 3 years, 9 months ago by irek.
    #16940
    xprinceps
    Participant

    I tried setting these to

    My server

    4000-4002

    4000

    TCP/UDP

    and the next screen gave me the option to choose my device, which I did. After a router reset, NoMachine still only shows local IP.

    #16938
    xprinceps
    Participant

    Hi Irek,

    Thanks for the help. I am using an AT&T BGW210 router, which, if my googling is to be believed, cannot use UPnP, so I am trying to follow your instructions for port forwarding. This link (https://www.att.com/esupport/article.html#!/u-verse-high-speed-internet/KM1215101) gives instructions for port forwarding on this router, but I’m not sure what settings to use.

    There is a “NAT/Gaming” tab in the router admin panel, with a drop-down list of applications, mostly the names of games. There is also a “Manage Custom Service” button on this panel, which leads to a screen with the following entry forms:

    Service Name

    Global Port Range

    Base Host Port

    Protocol (drop-down menu with TCP and UDP as the only options)

    ‘EnableUPnP’ is set to NX in server.cfg.

    #16981
    irek
    Participant

    Hello xprinceps,

    in that case, when the router doesn’t support UPnP or NAT-PMP protocol, you will have to enable port forwarding by hand on your router.

    From  “NAT/Gaming”  section, under “Manage Custom Service”  press button “Custom Services”

    1. Service Name – you can call it whatever you like

    ‘NoMachine’

    2. Global Port Range –  set whatever port you would like, this port will be used when connecting to NoMachine Server.

    24000 – 24000

    3. Base Host Port – by default 4000 (which is default port of NX )

    4000

    4. Protocol (drop-down menu with TCP and UDP as the only options)” – TCP

    TCP

    Then, when you add “Custom Services”, return to “NAT/Gaming”
    And set

    1. Service – service name just created

    ‘NoMachine’

    2. Needed by device – select IP of local machine where NoMachine server is installed

    Hope, this link can be usefull

    • This reply was modified 3 years, 9 months ago by irek.
    • This reply was modified 3 years, 9 months ago by irek.
Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.