Pulover’s Macro Creator not recording keystrokes on client

Forums / NoMachine for Windows / Pulover’s Macro Creator not recording keystrokes on client

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #27597
    Avatarthoatswold
    Participant

    I am using NoMachine to control a headless Windows 10 machine from a Windows 10 host. I am trying to record a macro using Pulover’s Macro Creator, which is based on AutoHotKeys. However, the macro recorder doesn’t record the remote keystrokes on the client machine, although it does record the remote mouse clicks. (The recording settings are correctly set to record both.)

    I have tried setting and unsetting the NoMachine option ‘Grab the keyboard input’ (although I’m not sure exactly what this does), but it hasn’t helped, unfortunately. Is there anything else I could try?

    Phil Gardner

    #27607
    Avatarthoatswold
    Participant

    Follow-up: I have now tried connecting to the client using RD instead of NoMachine. When I do so, Pulover’s Macro Creator does record keystrokes as well as mouse clicks.

    Therefore, either there is a relevant setting in NoMachine that I’m not aware of, or this is a bug in NoMachine.

    #27778
    Avatarfra81
    Moderator

    Hello,

    we investigated and found out that AutoHotKeys intentionally ignores input events injected on the system that are not coming from a physical device. NoMachine can’t overcome this, but you could still forward a keyboard to the server as a generic USB device from the NoMachine menu panel.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.