Quick Launcher from panel

Forums / NoMachine for Linux / Quick Launcher from panel

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #31162
    AvatarScattershot
    Participant

    So I have a connection configured in the nxplayer ui.  I have configured a new .desktop to launch nxplayer with the –session option.  I have pinned that desktop file to my icons-only task manager widget in my panel.

    The expectation is that clicking the pinned icon will launch the connection and the icon will show as active.

    What actually happens is that the connection window shows as a separate icon on the panel, leaving the pinned icon unhighlighted.  The pinned icon is briefly highlighted during the load process.

    Doing basically the same thing with Remmina works as expected so I don’t think that there’s anything wrong with the panel config.  My suspicion is that the process is launching the main window, which is associated with the launcher then spawning another one to run the connection.

    Any thoughts on how to fix this?

     

    Operating System: Manjaro Linux
    KDE Plasma Version: 5.20.4
    KDE Frameworks Version: 5.77.0
    Qt Version: 5.15.2
    Kernel Version: 5.9.16-1-MANJARO
    OS Type: 64-bit
    Processors: 12 × Intel® Core™ i7-8700K CPU @ 3.70GHz
    Memory: 31.3 GiB of RAM
    Graphics Processor: GeForce GTX 1060 6GB/PCIe/SSE2

    NoMachine: 7.0.211

    #31295
    AvatarTor
    Contributor

    Hi. I’m testing Manjaro 20.2:

    – Copy the original .desktop file with cp /usr/share/applications/NoMachine-player-base.desktop ~/Desktop/nomachine-session.desktop
    – Change Exec line of new .desktop by adding the option "--session <name>"
    – Double click the .desktop file to start the session
    – Right click the NoMachine icon in the task bar and select “Pin”

    From now on any new nxplayer icon is grouped with the one I’ve pinned in the bar.
    Could you share how you’re doing it?

    #31299
    AvatarScattershot
    Participant

    My method was essentially the same as your’s.

    I don’t have nomachine-session.desktop. I have NoMachine-base.desktop (plus a couple of variations for Unity and XFCE):

    [Desktop Entry]
    Encoding=UTF-8
    Comment=Access NoMachine computers over the network
    Exec=”/usr/NX/bin/nxplayer”
    Icon=NoMachine-icon
    Name=NoMachine
    StartupWMClass=nxplayer.bin
    Type=Application

    NotShowIn=Unity;XFCE;

    and NoMachine-nxs.desktop:

    [Desktop Entry]
    Encoding=UTF-8
    Comment=NoMachine session
    Exec=”/usr/NX/bin/nxplayer” –session
    Icon=NoMachine-desktop
    Name=NoMachine
    Type=Application
    MimeType=application/nx-session;
    NoDisplay=true

    There a couple of others for recording and video that don’t seem relevant.

    I followed your steps with both of the above files as a base. The results are the same. The icon pins fine on the task manager but when I close the window and re-open by clicking on the pinned icon, it opens the main window on the server settings page. It does not load the session. It does group however.

    If I find the desktop file again and double click it then the session loads and attaches to the pinned task manager icon and groups.

    #33334
    AvatarBritgirl
    Keymaster

    Just a quick update on this. We’ve been unable to reproduce the behaviour reported in this topic despite our continuous efforts. We will continue to investigate and will update the topic with our findings. I am going to close this topic in the meantime.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.