Raspberry PI 2 – Raspbian Jessie – no USB audio

Forums / NoMachine for Raspberry Pi / Raspberry PI 2 – Raspbian Jessie – no USB audio

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #12218
    seraphim_td
    Participant

    Hi,

    I am running Raspbian Jessie on my Raspberry Pi 2. I am not able to get the audio to redirect to my USB headset. On the Pi I have tested the audio and all works fine. I have used freerdp and rdesktop both have no issues with the audio. Is there a way to direct the audio and mic to a specific device in the NX client?

    Local OS: Raspbian Jessie – fresh install

    NX ver: NXPLAYER – Version 5.1.44 Free

    Target servers: Windows 2012 R2, Windows 7, Ubuntu 16.04.1 LTS

    NET: Local 1Gb

    #12246
    kroy
    Contributor

    You need to install pulseaudio. After installation you may need to setup NoMachine. To do that you can enter the following commands:

    sudo apt-get install pulseaudio
    sudo /usr/NX/scripts/setup/nxnode --audiosetup

    #12276
    seraphim_td
    Participant

    Thank you for the response, Kroy.

    pulseaudio is already installed on Raspbian Jessie. I went ahead and performed the steps you outline:

    “pulseaudio is already the newest version.”

    The nxinstallation.log is clean except for the CUPS module, which is not an issue since this is a fresh install of Raspbian. Attached are the screen shots of the connection after the setup. As you can see there is no audio option to select from. Currently in pulseaudio I have my headset as the default device.

    Attachments:
    #12286
    kroy
    Contributor

    Is the pulseaudio process running on the device (ps -Af | grep pulseaudio)? If not please launch it (you can execute command: pulseadio) and restart the test.

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.