Refusing connection to PulseAudio

Forums / NoMachine for Linux / Refusing connection to PulseAudio

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #1542
    kilfinge
    Participant

    Using  free nomachine 4.0.352 or 4.0.369 on server, I cannot make sound working and being forwarded to the client (4.0.369).

    In the /usr/NX/var/log/nxnode/C-(..)/session I can only see following warning:

    AudioIoPulseaudioClientConnection: WARNING! Cannot connect to PulseAudio: Connection refused

    sh: –: invalid option

     

    Please if anybody have a clue what would be the reason I would appreciate for help.

    Thank you.

    #1584
    Britgirl
    Keymaster

    Hi, we will need some more information from you:

    1) Distribution and version of the Linux system that you are using and whether it’s 32 or 64-bit.
    2) Enable debug logs in /usr/NX/etc/node.cfg, restart the server, start the session and reproduce the issue, then send us /usr/NX/var/log/nxserver.log
    3) After reproducing the problem (and while having session running) run the command:
    ‘ls -al /usr/NX/var/log/nxnode/C-(…)/audio’ where C-(…) is the current session’s log folder and tell us the output.

Viewing 2 posts - 1 through 2 (of 2 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.