Remote access to VM

Forums / NoMachine for Windows / Remote access to VM

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #30031
    AvatarMacGP
    Participant

    Hello,

    I can’t seem to get NoMachine Enterprise to work for me. I have a Win 10 VMware training machine and I’d like to have one person RDP into a hosted VM to act as an “instructor” with full access, while allowing “students” to remote in using the NoMachine Enterprise Client to view the screen for training.

    What I’m finding is that “students” are brought to the VM’s “physical” desktop logon screen instead of the instructor’s NM session. As I understand it, the NM Client is connecting to the “physical” desktop of the VM and not the instructor’s virtual RDP desktop. The only way I’ve been able to get it to work is to disable authorization for remote connections on the VM’s NM Service which then allows the instructor to connect with the VM using NoMachine. However, as a consequence, there’s no way to restrict student access to the screen, and I can’t have students playing with the system while the instructor is giving a demonstration.

    How can I allow an instructor to access the VM while limiting student access to view-only?

    Using:
    Win 10 1809 VMware for Host machine
    Win 10 1809 for all Client machines, including instructor
    NoMachine Enterprise Desktop 6.10
    NoMachine Enterprise Client 6.11

     

    Thanks,

    Mac

    #30066
    AvatarBritgirl
    Keymaster

    NoMachine will connect you to the monitor which is physically available on the server. It cannot connect you to a virtual display running on Windows in the background (only our Linux products support that feature).

    The only way I’ve been able to get it to work is to disable authorization for remote connections on the VM’s NM Service which then allows the instructor to connect with the VM using NoMachine.

    If you make the instructor a trusted user, he/she will be able to connect without needing desktop authorization. Students connecting with a secondary account(s) can then connect in view-only mode. Please see the guide for more information here:

    https://www.nomachine.com/DT02O00125&dn=enterprise%20desktop#10.3

    Remember to re-enable the “authorization required” that you have disabled.

     

    #30231
    AvatarMacGP
    Participant

    Thanks for the help Britgirl,

     

    I was able to get it sorted it out.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.