Remote connections to Windows server only work when public firewall is disabled

Forums / NoMachine for Windows / Remote connections to Windows server only work when public firewall is disabled

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #35466
    phaqlow
    Participant

    Hi,

    I am trying to connect from a Linux client to a Windows Server. I am able to establish a successful connection with a local server IP with or without disabling the Windows Public Firewall. However, when I try to use the public server IP, I am only able to form a remote connection if I disable the Windows Public Firewall otherwise it times out. I know my server isn’t behind a local router or anything because doing ipconfig /all from the command prompt gives the same public server IP.

    I have already checked the Windows Firewall settings and confirmed that all the NoMachine applications (server, client, player, node, etc) are allowed through the firewall on both public and private networks. I’ve also checked that similar firewall rules exist for incoming connections for both TCP and UDP variants for all those previously mentioned NoMachine applications.

    Ideally, I don’t want to have to disable my Public Firewall to be able to connect from remote. How should I fix this?

    Version: 7.6.2 (server and client, free versions)

    Server: Windows 10

    #35487
    fisherman
    Moderator

    I can only think about one possible case that you have enabled “Block all incoming connections, including those in the list of allowed apps” see screenshot.

    If that is disabled please try enabling NoMachine port 4000.

    #35489
    fisherman
    Moderator

    You can check enabled applications, ports in Advance firewall settings “Inbound Rules”.

    #35522
    phaqlow
    Participant

    I do not have “Block all incoming connections …” enabled.

    I have already checked the inbound rules and they’re all enabled for all ports, for both UDP and TCP for all the different NoMachine executables.

    #35715
    fisherman
    Moderator

    This issue does not look like nomachine problem, but firewall configuration that is blocking connection.  Possibly would be good to enable firewall logs and get information what is dropping connection. you can change Log dropped packets to yes.

    Attachments:
Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.