Remote mouse laggy in client

Forums / NoMachine for Windows / Remote mouse laggy in client

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #34212
    Avatarmmaenz
    Participant

    Hi,

    I’m using NoMachine to pass a Windows 10 second desktop to an iMac via direct ethernet link (no router, no hub, 1000MBits). The iMac acts as a second display for the Windows laptop, they are standing next to each other. On the Windows laptop is an hdmi dongle with some resistors to simulate a display. The Windows laptop is acting as NoMachine-server, the iMac is acting as NoMachine-client.

    Both machines are running the same version of NoMachine. I have turned show remote cursor on to use only one mouse for both displays and that it should behave as if the iMac is only a display.

    The problem is that the cursor lags under very reproducible circumstances. Initially the cursor is on the second (NoMachine-client) display and works really well, is responsive and doesn’t lag at all! But when I go to the first display (the laptop, NoMachine server) and back to second display the cursor gets slow, has a certain latency and it is getting hard to click menus, mark things or click on icons. If I move the iMac mouse the cursor gets “resetted” and works well like before. If I never go to the first display, the cursor is well all the time!

    I got used to wiggle the iMac mouse a bit to reset the cursor from time to time to circumvent the lag but it would be great if someone can have a further look what’s the reason for that??

    Thanks in advance

    -Michael

    (I know someone will answer that the product isn’t made for this scenario and I am aware of that! But as it seems that could be fixable I will give it a try.)

    #34226
    Avatarfra81
    Moderator

    Hi Michael,

    just a guess: did you try to check the ‘Disable frame buffering on decoding’ option in the session menu panel, Display settings (on the Mac)? By default, when there is no local input, NoMachine assumes that there is no user interaction with the desktop and starts buffering few frames on playback.

    #34281
    Avatarmmaenz
    Participant

    Indeed, this does the trick. Now everything works like a charm!

    Thank you very much…

    -Michael

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.