Remote terminals have the wrong keyboard layout

Forums / NoMachine for Linux / Remote terminals have the wrong keyboard layout

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #17431
    AvatarBob_von_Knobloch
    Participant

    I an running the free NoMachine 6.0.66_2_x86_64 on OpenSuse 32.3 && 42.1 on KDE Plasma.

    Remote terminals (either way round) have the wrong keyboard mapping (US English perhaps?), whereas all my PCs have German[nodeadkeys] keyboards. Is there a fix?

    Thanks,

     

    Bob von Knobloch.

     

    #17437
    Avatargraywolf
    Moderator

    Assuming KDE is the remote side, have you tried to change keyboard to German in the KDE settings?

    #17451
    AvatarBob_von_Knobloch
    Participant

    Thank you.

    It did not seem intuitive as the client had connected to an existing X-Session, already having the correct (German) keyboard layout, but I suppose I don’t understand how NoMachine works :=)

    #17460
    Avatargraywolf
    Moderator

    The client treats raw keyboard event. The server is the place where raw events are translated in a meaningful symbol on the basis of the current keyboard layout.

    Did changes in remote KDE settings take to any effect, by the way?

    Could you change SessionLogClean to “0” in /usr/NX/etc/node.cfg in your server, reproduce the problem and send to me the folder /usr/NX/var/log compressed?

    #17805
    Avataranutosho
    Participant

    I have the same problem.

    I am using  NoMachine 6.0.78_1_amd64.deb on debian Stretch with sddm on the server and client.

    As both pcs are in the same room I can access the server with nx as well as with a direct connected keyboard ans monitor.

    When I connect with NX the language chooser of the greeter only offers me US for the language (the flag at the top left). That’s specially annoying as I have special chars in my password which are hard to type with a us-keyboard layout.
    When I hit any key on the physical attached keyboard the flag (and keyboard layout) changes to German. When I hit a key on the keyboard of the NX client machine it switches back to US. Pretty weird.

    After login I can execute “setxkbmap -model pc105 -layout de” and get a German keyboard layout with nx as well as with the locally attached keyboard.

    #18552
    AvatarBritgirl
    Keymaster

    If the issue is still present,  we need to see the logs as requested by Graywolf. Instructions for extracting the logs are available here:

    https://www.nomachine.com/DT10O00163#1

Viewing 6 posts - 1 through 6 (of 6 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.