Remove warning about infinitely nested display

Forums / NoMachine for Linux / Remove warning about infinitely nested display

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #35566
    oleksii.a
    Participant

    Dear support,

    I am running NoMachine in docker container and get the following warning every time:

    Your client is connecting to your physical desktop. This will cause the display to be infinitely nested and your session likely to be unusable.

    Can I remove it by configuring server.cfg or by setting some configurations to nx server? Or in some other way programmatially?

    Thanks in advance.

    #35601
    Tor
    Contributor

    Hi. When you see that message you could check the box “Don’t show this dialog anymore” and never see it again, for any local connections. Is it not working, or do you need to pre-configure a bunch of different clients and you want to skip the message completely?

    #35602
    oleksii.a
    Participant

    The checkbox is working but this does not fit my use case. I want to skip that message completely, don’t bother users with it and do not show it at all.

    #35648
    Tor
    Contributor

    You could configure the client CFG to skip that message, by setting the following key to ‘false’:

    <option key="Show local desktop connection information" value="false" />

    Normally this CFG is located in $HOME/.nx/config, but you can start the client with an option to load the CFG from different paths:

    /usr/NX/bin/nxplayer --config /path/player.cfg

    The file ‘nxplayer’ is a script, you could edit it to add the ‘–config’ option.

    Meanwhile we’ll check how to improve the conditions triggering that message to avoid to show it in similar environments.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.