Resolution does not fit

Forums / NoMachine for Linux / Resolution does not fit

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #29846
    Avatarpredz
    Participant

    Hello,

    I know it’s a common issue but I’ve not been able to resolve it using many solutions I found, so I need your help if possible !

    I’m connecting from a Windows 10 physical machine to a Linux VM (Ubuntu 20.04).

    I installed Gnome desktop (gnome-session) on the VM and have been able to connect using NoMachine, easy.

    Thing is that the default resolution is “1152×864”, and there are no other available resolutions.

    So I tried the “xrandr” solution to add a custom resolution. I’ve been able to select “1920×1080 (16:9)” resolution after that, but thing is that it still doesn’t fit the screen (see screenshot).

    By the way, when I added the custom resolution with xrandr, it showed me an error/warning : “xrandr: Failed to get the size of gamma for output default”. But the resolution was still added to the list.

    I tried every “combination” of display settings on the (client side) NoMachine soft.

    Does anyone have a hint about my issue ?

    – Windows 10 (client)
    – Ubuntu 20.04 (host)
    – NoMachine v6.12

    Regards.

    Attachments:
    #29852
    Avatarfisherman
    Moderator

    Hello Predz,

    What i have noticed is that you are having the Ubuntu virtual machine:
    – I would recommend to install hypervisor drivers and verify if your machine is able to use different resolutions.

    Or You may try to switch off your X server and let NoMachine create display for you. You can stop or disable you Display Manager, and create a connection to that desktop.

    Visit this link for more information about the configuration:
    https://www.nomachine.com/FR10L02842

    #29854
    Avatarpredz
    Participant

    Both Windows and Linux machines are different physical machines.

    They both are on the same LAN. The only physical machine I have in hand is the Windows (client) machine. I don’t have access to the physical Linux machine and I can only “login as root” or restart/stop the machine.

     

    #29861
    Avatarfisherman
    Moderator

    I understood it is virtual machine as you have mentioned “Linux VM (Ubuntu 20.04)”.

    If you Linux machine is without monitor attached probably Linux X server if forcing one resolution. Possibly you can attach hdmi dummy dongle or you can let NoMachine create a display on the fly rather than using physical one.

    Try to turn off lightdm or gdm:
    sudo service lightdm stop

    and then restart NoMachine server:
    sudo /usr/NX/bin/nxserver –restart

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.