Resolution issue while connecting to Debian from Windows

Forums / NoMachine for Windows / Resolution issue while connecting to Debian from Windows

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #20762
    Avatarravi
    Participant

    Hi All,

    I have installed NoMachine client on Win10 and NoMachine server on Debian8. While I remotely connect to Debian its resolution is getting changed to lower value. Even I can not change this remote connection resolution to widescreen using Debian settings. Can any one help me resolving this issue?

    I have below details and snap of remote login attached .

    NoMachine client version on Windows 10         —-      free version  6.2.4

    NoMachine server version on Debian 8       —-   free version     6.2.4

    Actual resolution of Debian8 on my lcd panel —-   1920×1200

    Resolution of Debian8 while remotely connected from Win10 on my lcd panel —-   1366×768  (degrade resolution value)

    Debian desktop environment ——  Cinnamon

    xrandr -q output:

    Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192

    LVDS1 connected primary 1366×768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm

    1366×768      60.10*+

    1360×768      59.80    59.96

    1024×768      60.00

    800×600       60.32    56.25

    640×480       59.94

    VGA1 disconnected (normal left inverted right x axis y axis)

    HDMI1 disconnected (normal left inverted right x axis y axis)

    DP1 disconnected (normal left inverted right x axis y axis)

    HDMI2 disconnected (normal left inverted right x axis y axis)

    HDMI3 disconnected (normal left inverted right x axis y axis)

    DP2 disconnected (normal left inverted right x axis y axis)

    DP3 disconnected (normal left inverted right x axis y axis)

     

     

    I am expecting the actual widescreen resolution  1920×1200 even with remote login.

    Thanks,

    Ravi

     

     

    #20774
    Avatarbucu
    Contributor

    Hi,
    in order to investigate further we would need the output of xrandr -q when not connected via NoMachine. Can you please paste it here?

    #20791
    Avatarravi
    Participant

    Hi,

    Please find the output of   xrandr -q  when not connected via NoMachine.

    ——————————————————————————————

    Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 8192 x 8192

    LVDS1 connected (normal left inverted right x axis y axis)

    1366×768      60.10 +

    1360×768      59.80    59.96

    1024×768      60.00

    800×600       60.32    56.25

    640×480       59.94

    VGA1 disconnected (normal left inverted right x axis y axis)

    HDMI1 connected primary 1920×1200+0+0 (normal left inverted right x axis y axis) 518mm x 324mm

    1920×1200     59.95*+

    1920×1080     60.00    50.00    59.94    30.00    25.00    24.00    29.97    23.98

    1920x1080i    60.00    50.00    59.94

    1600×1200     60.00

    1280×1024     75.02    60.02

    1152×864      75.00

    1280×720      60.00    50.00    59.94

    1440x576i     50.00

    1024×768      75.08    60.00

    1440x480i     60.00    59.94

    800×600       75.00    60.32

    720×576       50.00

    720×480       60.00    59.94

    640×480       75.00    60.00    59.94

    720×400       70.08

    DP1 disconnected (normal left inverted right x axis y axis)

    HDMI2 disconnected (normal left inverted right x axis y axis)

    HDMI3 disconnected (normal left inverted right x axis y axis)

    DP2 disconnected (normal left inverted right x axis y axis)

    DP3 disconnected (normal left inverted right x axis y axis)

    —————————————————————————————————-

     

     

    Thanks.

    #20803
    Avatarravi
    Participant

    hi,

    any update on this issue?

    thanks.

    #20809
    Avatarravi
    Participant

    so here are some more details about my setup…

    My Debian laptop where NoMachine server is running has broken monitor which does not work. Similar case with my windows laptop also having NoMachine client. Therefore I use an external widescreen Dell monitor connected with both laptops using HDMI monitor switch.

    When I switch my Dell monitor to Debian for direct connection, I get my widescreen resolution. However when I switch-over my Monitor to Windows and try to remote connect from win to Debian using NoMachine, I do not get the widescreen resolution as expected.

    I used the below command in Debian to disable sleep , still not working as expected.

    sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target

    Do you think we have any issue because of Dell monitor or because of HDMI monitor switch in my setup?

    thanks…

    thanks.

    #20820
    Avatarbucu
    Contributor

    You are using a monitor switch and this is why you are seeing the behaviour. NoMachine is not responsible for that. You can’t have image on both hosts at the same time.

    When you connect to the Debian with monitor switch set to Windows host you’ll see only the internal display. This would explain the lower resolution you get (max of the internal display).

    #20836
    Avatarravi
    Participant

    hi bucu,

    thanks for you help. I have removed the monitor switch and now i am getting widescreen resolution.

    However I observed access is sluggish particularly when i open image, video or even web browser.

    Can you please let me know how can i optimize the setup to get seamless access?

     

    thanks….

     

    #20851
    Avatarbucu
    Contributor

    In order to detect what is the cause of sluggishness: network or hardware resources, for a start I would:

    – check CPU usage on both client and server side;

    – gather NoMachine session statistics as shown in https://www.nomachine.com/DT10O00157&dn=session%20menu#9.

    Please also make sure you are using H.264 encoding. More info in this article:

    What do I need to do to allow NoMachine software to use H.264?
    https://www.nomachine.com/AR10K00706

    #20879
    Avatarravi
    Participant

    Hi bucu,

    Please find the logs attaches as you have requested. Please let me know if you find any issue.

    thanks.

    #20897
    Avatarbucu
    Contributor

    Hi again,

    I don’t see you’ve had enabled H.264. Please follow this link. If you did so and still can’t use H.264 then we would need full set of logs when the slowdown is present in session. You can do it by following those instructions.
    Can you confirm the statistics had been taken when the slowdowns occured? You’ve only sent the client side CPU usage. Can you do the same for server side? During a slowdown run top -b -n 1 > top.out and send us the top.out file.

    • This reply was modified 2 years, 1 month ago by Avatarbucu.
    • This reply was modified 2 years, 1 month ago by Avatarbucu.
    • This reply was modified 1 year, 8 months ago by AvatarBritgirl.
    #20895
    Avatarravi
    Participant

    Hi bucu,

    as per the link shared by you, I installed libx264 on Debian running NoMachine server.

    Still I see  “codec VP8” in display settings (attached snaps and logs in previous mail).

    Could you please help me to figure out the reason and fix for this?

    you support will be highly appreciated.

     

    thanks…

     

    #20919
    Avatarbucu
    Contributor

    Provided you’ve followed the instructions in the article correctly H.264 will work. The alternative is to use AVC pack which will do all the configuration and libs set up for you, out of the box.
    Either way, the only way we can get an idea that you’ve set up everything correctly is with the full set of logs. Instructions were pasted above. Note that the statistics I have asked in the beggining are not the same as logs from server and client side. Please include the top.out file as well.

Viewing 12 posts - 1 through 12 (of 12 total)

This topic was marked as solved, you can't post.