Router doesn’t UPnP, doesn’t nx, now what?

Forums / NoMachine for Windows / Router doesn’t UPnP, doesn’t nx, now what?

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #11804
    Uhuk
    Participant

    I am trying to use NoMachine “For The People” 5.1.26.0 to get access to my Windows 10 desktop from outside my home network, and cannot do so as the NoMachine service insists that there is no outside. Everything works fine internally (connecting from Windows 10 to Windows 10).

    I have a Lynksys E3000, which doesn’t UPnP. I’m familiar with manually configuring it for port forwarding for various other programs. For the curious, I’m connected to the router by cable and I’m on the Single Port Forwarding page.

    I try to follow the documentation for manual port forwarding and rapidly run into several problems.

    1) The documentation refers to NX as a core protocol. It isn’t. I’m pretty sure you guys are using TCP (with the option of UDP for streaming media). Instructing users to forward port 4000 for the NX protocol is going to be tricky since that’s not a thing.

    2) I forwarded port 4000 external for both protocols to 4000 internal, and the NoMachine server still thinks I don’t have an external IP address. I also tried 24980 external to 4000 internal, and 24980 external to 24980 internal.

    3) I have no firewall software, I don’t have any “security suites” that could complicate the issue, and I’ve firmly instructed the windows firewall to keep it’s sticky fingers off the NoMachine processes.

    Out of frustration I’ve tried port range forwarding rather than single port forwarding (range: 4000 to 4000) and even put the server in the DMZ for my router, but not surprisingly that wasn’t any different.

    I appreciate the program is trying to be user friendly, but is there a “less user friendly” way to use it? UPnP just isn’t an option.

     

    This has been an ongoing problem since I first installed NoMachine in May, and I just can’t make it go.

    #11830
    kroy
    Contributor

    You won’t see your external IP on NoMachine Welcome Page if you don’t enable UPnP on your router. You can get your public IP address from whatismyip[dot]com, for example. Please check again your configuration on the router that for sure you choose correct IP of machine and port.

    Instructions how to connect to NoMachine when the server is behind a NAT router or a firewall you can find there: https://www.nomachine.com/AR11L00827. Informations about default ports used by NoMachine: https://www.nomachine.com/AR01L00770.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.