Router on double-NAT – Can’t get external IP for remote connections

Forums / NoMachine for Mac / Router on double-NAT – Can’t get external IP for remote connections

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #29694
    Avatargoborgh
    Participant

    I’m at a building that provides it tenants with internet, and I have an Airport Extreme router connected to the network port in the wall, the router shows Double-NAT warning  that I have it on ignore, I had no problem so far, except that when trying to setup NoMachine to access from an outside location I cannot get the external IP address to show up, looks to me I’m getting the address from the building.

    I’ve been using [removed] recently and I’d like to move to NoMachine but I need to be able to access it externally.

    What can I do to get it to show the external IP?

     

    Thanks!

    #29736
    Avatarkroy
    Contributor

    It appears that Upnp is not supported on your router.

    However you could try forward port manually. To do that you should pass traffic to port 4000 (NX protocol), 22 (SSH protocol on Linux/MacOSX). Follow your router instruction to know how to configure that (guide you can also find in the internet, for example from there: https://portforward.com/apple/airport-extreme/). Your external address you can find for example there: https://www.whatismyip.com/.

    #29742
    Avatargoborgh
    Participant

    The router actually supports Upnp, they just call it “Enable NAT Port Mapping Protocol”, or so I’ve heard.

    When I try to setup port mapping, I’m limited by “10.0.1.xxx” address, it doesn’t let me edit the whole address unfortunately.

    Also, the issue is that I’m behind a second router, the building one.

    Still I still believe this router is not good for this kind of things, it’s very limiting on what you can do, what router would you recommend?

    #29749
    Avatarkroy
    Contributor

    Buying new router is not necessary. Just check port forwarding. In link from previous post you have instructions. just use local IP from machine with nxserver and use port 4000. Then check your external IP on https://www.whatismyip.com/ and then use that IP and port 4000 on client side to connect.

    #29756
    Avatargoborgh
    Participant

    Hi Kroy,

    Unfortunately those instructions don’t take into consideration the double router situation.

    Airport Extreme doesn’t allow me to put an external IP in the port mapping, it just restricts me to the 10.0.1.x, where x is the only option I have available to change.

    Perhaps a change in recent firmware, I heard dydns stopped supporting the newer firmwares.

    #29968
    AvatarBritgirl
    Keymaster

    Airport Extreme doesn’t allow me to put an external IP in the port mapping, it just restricts me to the 10.0.1.x

    You don’t need to enter the external IP.

    Quoting from the instructions at the link provided, you enter the IP address (the local IP as Kroy specified) that you are forwarding ports to in the Private Address box.

    #29969
    Avatargoborgh
    Participant

    In any case, doing that doesn’t make NoMachine see the external IP address, perhaps the issue is not with the router itself but with NoMachine.

    #29980
    AvatarBritgirl
    Keymaster

    It can be that your router doesn’t support UPnP. Or that our UPnP doesn’t support your router :-). This shouldn’t affect your ability to connect, even from the outside. Many routers that don’t support the query for the external IP still accept the commands required to enable port forwarding.

    Some tips are available here:
    How to connect to NoMachine when the server is behind a NAT router or a firewall
    https://www.nomachine.com/AR11L00827

    The alternative is to wait for the upcoming functionality of NoMachine Network:

    https://www.nomachine.com/FR07J02731

    #29987
    Avatargoborgh
    Participant

    At home I have the exact same router and I can see the external IP address. At my office, like I explained, I’m being provided access through the building and the IP address I get is the one from the building’s IP, not the one from outside.

    In short, with the same router on both location, one is available to access from an outside location and the other doesn’t.

    #29992
    AvatarBritgirl
    Keymaster

    Because UPnP doesn’t support the double NAT scenario, you would need to enable port-forwarding on both routers. You should contact whoever is in charge of the other router and ask if this is possible.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.