RSA key-based SSH authentication fails on NX 4.1.29

Forums / NoMachine for Mac / RSA key-based SSH authentication fails on NX 4.1.29

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #2448
    Avatarheywood
    Participant

    Looking forward to working with the new build, but I’ve found that the key-based SSH authentication still does not work for me. Perhaps there is something wrong with my config. My setup is as follows:

    Server: Ubuntu 12.04.4 LTS (Precise), NX 4.1.29 installed from the .deb file via dpkg.

    Client: MacOS (10.6.8), NX 4.1.29 installed from .dmg file. Config is host=(correct IP address), port=(correct port number), protocol=SSH, user=(correct username), auth=”Private key”, proxy=no. Under the “Advanced” section, “Use the system login” is selected, and the settings for that are auth method=Private key, path to id_dsa file=(correct path), forward authentication=UNchecked.

    I verified that I can connect from the OSX box to the Ubuntu box using key-based authentication from the command line. Doing so with a verbose flag (-vvv) shows that the id_dsa file is indeed being used for authentication.

    But when I try to log in from the NX client on the OSX box, I get “Running NoMachine sessions over a SSH connection is not supported on this server. Do you want to switch your connection to using the NX protocol?”

    I verified that nxserver is running on the Ubuntu box:

    /usr/NX/bin$ ./nxserver –status
    NX> 161 Enabled service: nxserver.
    NX> 161 Enabled service: nxd.

    Is there some additional configuration I can do on the server end to make this work? Or am I missing something else?

    Thanks very much in advance for any pointers,

    -H.

    #2508
    Avataradp
    Participant

    Hello,

    It appears that you are using NoMachine (free) which doesn’t support the SSH protocol. You can use key-based authentication with the NX protocol, a step-by-step how to is available here: http://www.nomachine.com/AR02L00785

    If you need to use the SSH protocol, you should consider using NoMachine Worstation instead.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.