Screen flicker when connected to Linux systems

Forums / NoMachine for Linux / Screen flicker when connected to Linux systems

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #36552
    josys36
    Participant

    So I am connecting to a couple Fedora Workstation systems from my Mac. The connections work but when I connect to Fedora Workstation on my Lenovo P50 workstation I often get a strange screen flicker at the top of the screen. This seems to happen most often when I’m opening up or using a web browser in Fedora. On my other system using Fedora Workstation I don’t seem to have this issue. I’m guessing that it’s due to the P50 using Nvidia for it’s graphics instead of the other system using just Intel graphics. Has anyone else experienced this issue and had any luck dealing with it? It’s not a major thing as I only remote to these two systems for short periods of time, but it sure can get annoying.

    I also experienced this same issue when using Linux Mint on the same P50 workstation and it seems to also be a problem in Fedora 35.

     

     

    Thanks!

    #36588
    graywolf
    Moderator

    Hello. Would you tell me the version of the nvidia driver?

    #36593
    josys36
    Participant

    The driver version is 495.44

     

     

    #36674
    graywolf
    Moderator

    Hello, it is possible that problem is due to the driver of the video card.

    Anyway, I’d like to try to reproduce the same problem. I’d need to know the desktop environment (Gnome, KDE, MATE, etc) you have been using when the problem showed up. That should help to replicate your setup as near as possible.

    #36705
    josys36
    Participant

    Fedora Workstation 35 running the KDE desktop environment.

    #36856
    josys36
    Participant

    I’m now running driver 495.46

    Same issue exists.

    Thanks,

     

    Jason

    #36867
    ludo3232
    Participant

    Hi,

    Try to disable “Allow Flipping” in Nvdia settings panel

     

     

    #36876
    josys36
    Participant

    Well that has made a huge difference. So far I have had no screen flicker at all. I’ll keep testing and if I see something I’ll report back.

    Thanks!

     

    Jason

Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as solved, you can't post.