Selecting different desktop environment NoMachine 5

Forums / NoMachine Terminal Server Products / Selecting different desktop environment NoMachine 5

  • This topic has 1 reply, 2 voices, and was last updated 6 years ago by kroy.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #12307
    carlilek
    Participant

    We are using NoMachine Terminal Server on Linux, and I can’t figure out how to allow users to select a different DE when they start a session. It seems to be defaulting only to Gnome, while these machines have KDE, Gnome, and MATE installed. Any tips?

    #12318
    kroy
    Contributor

    Hi,
    To change the default desktop environment in NoMachine virtual sessions, you can replace the value in the node configuration key DefaultDesktopCommand. To do that, edit /usr/NX/etc/node.cfg, uncomment DefaultDesktopCommand (if it’s commented) and change the value inside the quotes.

    Change to KDE desktop:
    DefaultDesktopCommand “/usr/bin/startkde”

    Change to MATE desktop:
    DefaultDesktopCommand “/usr/bin/mate-session”

    There is also an other possibility: you can choose desktop between GNOME or KDE from list. To do that, edit the server configuration file. Uncommment ConnectPolicy and change the desktop value to 1. Now you can list all the desktop types set in the AvailableSessionTypes key.
    Edit /usr/NX/etc/server.cfg and change:

    #ConnectPolicy autocreate=1,autoconnect=1,automigrate=1,desktop=0,dialog=0

    to

    ConnectPolicy autocreate=1,autoconnect=1,automigrate=1,desktop=1,dialog=0

    But as it is mentioned – it shows GNOME and KDE. MATE is not supported with this option for the moment. You can follow our Feature Request (https://www.nomachine.com/FR09L02833) and check the ‘notify me’ box to receive a notification when the feature has been released.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.