Send Windows key combinations to remote

Forums / NoMachine for Linux / Send Windows key combinations to remote

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #38580
    amateo
    Participant

    Hello,

    I have an ubuntu 20.04 desktop connecting to another Ubuntu 20.04 desktop, both with NoMachine 7.9.2 package. I use NoMachine in window mode, not full screen.

    The problem I have is that whenever I push the Windows key, the combination is applied to my local system, not the remote. If I manually select the “Grab the keyboard input” in the menu panel, then windows key is sent to the remote, but when I left the NoMachine window the “grab the keyboard input” is marked as unselected and I have to manually select it again.

    That wouldn’t be a great problem if Ctrl+Alt+K was grabbing the keyboard, but although I use this combination, keyboard is not grabbed and I have to select the option from the menu panel.

    Any help? Thank you.

    #38634
    Britgirl
    Keymaster

    Hi, we are checking this and will update the topic soon.

    #39306
    Britgirl
    Keymaster

    Can you update to the latest version 7.10, both sides, and tell us if you are still experiencing the issue?

    #39327
    amateo
    Participant

    I’m already running version 7.10.1-2 on both sides. I don’t remember how I downloaded it this version, because in your web latest version is 7.10.1_1.

    #39344
    Britgirl
    Keymaster

    ‘Grab the keyboard input’ option enables the so-called ‘passive grab’ of the keyboard, but it is also possible to enable the ‘active grab’. In order to try this, please quit the NoMachine player application completely (you can do this from the NoMachine icon in the tray) and start it again from the terminal using the following command:

    /usr/NX/bin/nxplayer --activegrab

    After that, whilst the session is running, go back to the menu and select the box for enabling ‘grab the keyboard’. Does this help?

    #39518
    jigglywiggly
    Participant

    This only happens on X11 strangely, Wayland seems fine.
    I am using Ubuntu 22.04

    I tried using

    /usr/NX/bin/nxplayer --activegrab

    But it did not help, the super key still is not passed through to the host. I am using NoMachine 7.10.1

    The “Grab the keyboard input” is selected

    #39549
    Britgirl
    Keymaster

    Jigglywiggly, this could be a different issue?

    Pressing the Super key doesn’t work, you say. To do exactly what? Is Ubuntu 22.04 the client or is it the server? More details about your set-up (OS, version and NoMachine products) would be useful. Also, what kind of session are you running?

    #39566
    jigglywiggly
    Participant

    Ah, I wasn’t entirely correct. There is no difference between X11/Wayland. Key combos like alt + tab are forwarded correctly.

    But the Windows/super key is not forwarded to the host.

    The host is Ubuntu 20.04, client is Ubuntu 22.04

     

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.