Server audio not muted

Forums / NoMachine for Linux / Server audio not muted

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #29650
    Avatarfishnet37222
    Participant

    I’m using the free version of NoMachine to connect to my Fedora 32 laptop from my Windows 10 PC.  I have the option selected to mute audio on the server but I still hear sound coming from both my laptop and my desktop whenever I play audio in the Fedora 32 session.

    I’m using NoMachine version 6.11.2 on both the laptop and the desktop.  On the laptop I’m running Gnome 3.36.6 on X.

    #29808
    Avatarwitek
    Participant

    Hi,

    We could not reproduce this issue in your evironment. What output device are you using on laptop (built in speakers or something else)? Did you try to uncheck and check again “Mute audio on the server” option?

    Please, can you provide also the output of these commands when the NoMachine session is running:

    1. List files in /dev/snd:

    ls -lrt /dev/snd

    2. Check if PCM mixer control is available for specified sound card:

    for dev_id in $(ls /dev/snd | grep controlC | sed -e 's/controlC//g'); do amixer -c $dev_id get PCM; done

    3. List available sinks

    pacmd list-sinks > list_sinks.log

    and attach “list_sinks.log” in you reply.

    #29810
    Avatarfishnet37222
    Participant

    I’ve tried disabling and re-enabling the mute server audio option with no change in behavior.

    The output of the first command:

    total 0
    drwxr-xr-x. 2 root root 80 Oct 4 18:20 by-path
    crw-rw----+ 1 root audio 116, 33 Oct 4 18:20 timer
    crw-rw----+ 1 root audio 116, 1 Oct 4 18:20 seq
    crw-rw----+ 1 root audio 116, 2 Oct 4 18:20 controlC1
    crw-rw----+ 1 root audio 116, 10 Oct 4 18:20 hwC0D0
    crw-rw----+ 1 root audio 116, 11 Oct 4 18:20 hwC0D2
    crw-rw----+ 1 root audio 116, 12 Oct 4 18:20 controlC0
    crw-rw----+ 1 root audio 116, 5 Oct 4 18:21 pcmC0D3p
    crw-rw----+ 1 root audio 116, 6 Oct 4 18:21 pcmC0D7p
    crw-rw----+ 1 root audio 116, 7 Oct 4 18:21 pcmC0D8p
    crw-rw----+ 1 root audio 116, 8 Oct 4 18:21 pcmC0D9p
    crw-rw----+ 1 root audio 116, 9 Oct 4 18:21 pcmC0D10p
    crw-rw----+ 1 root audio 116, 4 Oct 4 18:21 pcmC0D0c
    crw-rw----+ 1 root audio 116, 3 Oct 5 07:06 pcmC0D0p

    The output of the second command:

    Simple mixer control 'PCM',0
    Capabilities: pvolume
    Playback channels: Front Left - Front Right
    Limits: Playback 0 - 255
    Mono:
    Front Left: Playback 0 [0%] [-51.00dB]
    Front Right: Playback 0 [0%] [-51.00dB]
    amixer: Unable to find simple control 'PCM',0

    I’ve attached the output of the third command as requested.

    #29828
    AvatarBritgirl
    Keymaster

    Can you send the attachment directly to forum[at]nomachine[dot]com, please put the title of the topic as the subject of your email.

    #30777
    AvatarBritgirl
    Keymaster

    Hi, this bug has been fixed in version 7 – please download it, and the topic can be closed.

    Reference: https://www.nomachine.com/TR12R09944

    #30780
    Avatarfishnet37222
    Participant

    I don’t know if Fedora 33 changed anything, but I just tested this and I still hear sound from the server when I have the mute server audio option enabled.

    Here is the output from the first two commands you asked for previously:

    [dave@localhost ~]$ ls -lrt /dev/snd
    total 0
    crw-rw----+ 1 root audio 116, 33 Dec 18 04:36 timer
    crw-rw----+ 1 root audio 116,  1 Dec 18 04:36 seq
    crw-rw----+ 1 root audio 116,  2 Dec 18 04:36 controlC1
    crw-rw----+ 1 root audio 116, 11 Dec 18 04:36 hwC0D2
    crw-rw----+ 1 root audio 116, 12 Dec 18 04:36 controlC0
    crw-rw----+ 1 root audio 116, 10 Dec 18 04:36 hwC0D0
    drwxr-xr-x. 2 root root       80 Dec 18 04:36 by-path
    crw-rw----+ 1 root audio 116,  5 Dec 18 04:48 pcmC0D3p
    crw-rw----+ 1 root audio 116,  6 Dec 18 04:48 pcmC0D7p
    crw-rw----+ 1 root audio 116,  7 Dec 18 04:48 pcmC0D8p
    crw-rw----+ 1 root audio 116,  8 Dec 18 04:48 pcmC0D9p
    crw-rw----+ 1 root audio 116,  9 Dec 18 04:48 pcmC0D10p
    crw-rw----+ 1 root audio 116,  3 Dec 18 04:48 pcmC0D0p
    crw-rw----+ 1 root audio 116,  4 Dec 18 04:48 pcmC0D0c
    [dave@localhost ~]$ for dev_id in $(ls /dev/snd | grep controlC | sed -e 's/controlC//g'); do amixer -c $dev_id get PCM; done
    Simple mixer control 'PCM',0
    Capabilities: pvolume
    Playback channels: Front Left - Front Right
    Limits: Playback 0 - 255
    Mono:
    Front Left: Playback 255 [100%] [0.00dB]
    Front Right: Playback 255 [100%] [0.00dB]
    amixer: Unable to find simple control 'PCM',0

    You can see the output of the third command at https://pastebin.com/GwWqAjzR.

    #30786
    Avatartsotne
    Participant

    Hello again,
    please for more investigation, send us logs.

    Here you can find article, how to capture logs automatically.

    Connect to server with “mute server” option and few times enable/disable “mute server” option from context menu (right upper corner, in audio section).

    And once again, please give us output of available sinks when “mute server” option is enabled.

    #30794
    Avatarfishnet37222
    Participant

    I’ve created the logs as requested.  The output shown in my post above shows the available sinks when “mute server” option is enabled.

    #30829
    Avatartsotne
    Participant

    Thank you for logs.

    Please also upload nxserver.log from:

    ~/.nx/nxserver.log

    or (~ refers your home directory)
    /home/$USER/.nx/nxserver.log

    #30834
    AvatarBritgirl
    Keymaster

    Hi, fishnet37222, firstly, please update the software (both sides) because we recently released version 7 and you should see if this changes anything – a number of fixes were introduced which were related to audio on Linux.

    If the problem is still there, please resubmit everything plus the additional files that tsotne requested. Thank you!

    #30835
    Avatarfishnet37222
    Participant

    I’ve checked the version on both my Fedora laptop and my Windows 10 PC and now have them both running the most recent version.  The audio is still not muted on the Fedora laptop when I connect from my Windows 10 PC.  I’ve generated and attached the logs as requested.

    #30843
    Avatartsotne
    Participant

    Hi again,
    please do:
    1. Enable logs on server side:
    sudo /etc/NX/nxserver --debug --enable all

    2. restart NM on server side:
    sudo /etc/NX/nxserver --restart

    3. Connect again to server with mute option enabled and again few times enable and disable it from context menu.

    4. When enabled mute option, check sinks again (it’s important)
    pacmd list-sinks > list_sinks.log

    5. Disconnect from server and give us:

    • list_sinks.log
    • nxserver.log from ~/.nx/nxserver.log
Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.