Server doesn’t start on Windows 7

Forums / NoMachine for Windows / Server doesn’t start on Windows 7

Tagged: , ,

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #25839
    AvatarVQuest
    Participant

    I have a problem with server starting on Windows 7. After installation and reboot server status stays still stopped. Running server with run button does not lead to successfully running. Based on forum discussions and troubleshooting section I have reinstalled NoMachine, when I make new registration for nxlsa service, I check windows lsa service state and it was in NOT protected mode.  I make extended logs for server and node, and cannot understand trouble reason.

    Please help me to find a problem. Logs archivve is attached .

    Attachments:
    1. NoMachine_log.zip
    #25885
    AvatarGuro
    Contributor

    Hello.

    Could you provide opened pipe name information?

    You just need to open PowerShell and input

    [System.IO.Directory]::GetFiles(“\\.\pipe\”)

    Please, check if listed pipe name contains pipes with nx prefix.

    like:

    \\.\pipe\nxdevice-bc72a506-0e0c-4bff-b6f8-c2b6aa32e906

    \\.\pipe\nxfsd-709fd562-36b5-48c6-9952-302da6218061

    \\.\pipe\nxserver-WqJhjF9jm0-l0dmS-Hs8dXKc0

    \\.\pipe\nxsspi-ef0b693a-97e0-4d61-8582-a24f630526e1

    You can use  pipelist.exe tool for this, also.

    Thanks.

    #25887
    AvatarVQuest
    Participant

    Thank you for you responding. That’s a partial output, that contains nx prefix pipe names.

    \\.\pipe\nxdevice-bc72a506-0e0c-4bff-b6f8-c2b6aa32e906
    \\.\pipe\nxfsd-709fd562-36b5-48c6-9952-302da6218061
    \\.\pipe\monitorPipe
    \\.\pipe\nxserver-WqJhjF9jm0-l0dmS-Hs8dXKc0
    \\.\pipe\nxsspi-ef0b693a-97e0-4d61-8582-a24f630526e1
    \\.\pipe\srvsvc

    #25901
    AvatarGuro
    Contributor

    Hello

    Could you reinstall NoMachine with disabled Firewall(if it enabled) and disabled Antivirus (if it installed)?

    We try to reproduce this issue in our labs.

    Thanks

    #25990
    AvatarVQuest
    Participant

    ok, I’ve done this before, but I try one more time.

    #26483
    AvatarBritgirl
    Keymaster

    Did you reinstall successfully?

    #26515
    AvatarDaveXS
    Participant

    I have the same problem the original poster had.  At least on two machines.  I’ve installed NoMachine on five PCs, three work as expected, two do not.  In both cases the computer management window shows NoMachine Device service as started but the NoMachine Service window shows it is stopped.  Trying to start the service fails.  I’ve tried reinstalling, uninstalling and reinstalling, nothing seems to change.

    All are Windows 7 64.

    #26501
    AvatarVQuest
    Participant

    Yes, but I got the same result. I have made several attempts futher and have had no succes. This time all repeated.

    #26605
    AvatarGuro
    Contributor

    Current known problem with Windows is related to NoMachine installation folder.

    If you install Windows in a folder which is located in mounted disk (as shared folder), the service is unable to start because it can’t match NoMachine module path.

    Please ensure that your NoMachine install path is located in the standard logical disk or allow NoMachine to choose default path.

    For user DaveXS, could you send compressed NoMachine log data to us, so we can check?

    You need to compress folder C:\ProgramData\NoMachine\var\log

    #26617
    AvatarDaveXS
    Participant

    Here’s the zipped directory.  WinZip said some of the file may be corrupt.

    Thanks for your help.

     

    Attachments:
    1. log-1.zip
    #26633
    AvatarVQuest
    Participant

    Ok, thank you. I try to reinstall NoMachine one more time and a especially keep of installation folder.

    #26674
    AvatarCato
    Contributor

    Hello,

    We have found that in some rare cases NoMachine Server is unable to find POSIX.dll, which prevents it from working properly. Workaround which may help is to copy POSIX.dll from:

    <NoMachine_installation_dir>\lib\perl\POSIX.dll

    to <NoMachine_installation_dir>\bin directory.

Viewing 12 posts - 1 through 12 (of 12 total)

This topic was marked as solved, you can't post.