Server not displaying external IP address

Forums / NoMachine for Windows / Server not displaying external IP address

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #35193
    manskirtbrew
    Participant

    I’ve read a bunch of threads here with the same issue, but haven’t found any solved threads, so I apologize if it’s out there and I missed it.

    I have a Windows 10 PC connected to a Linksys WRT54GL wireless router. NoMachine server status only shows the internal IP:

    Router is configured to enable UPnP:

    I did see the article on how to connect behind a firewall. The article says to set the EnableUPnP flag in the config file, which I have:

    #
    EnableUPnP NX

    #

    Checked on the UPnP status and map:

    C:\Program Files (x86)\NoMachine\bin>nxserver –upnpmap
    Local IP                   192.168.1.102
    Gateway IP                 192.168.1.1
    External IP                243.5.0.0

    C:\Program Files (x86)\NoMachine\bin>nxserver –upnpstatus
    Local IP                   192.168.1.102
    Gateway IP                 192.168.1.1
    External IP                243.5.0.0

    I did see one suggestion of checking the Gateway Port box under the server configuration, but this gives me a “Failed to map the port on the gateway” error:

    Logs attached.

    Attachments:
    #35217
    Britgirl
    Keymaster

    Please submit images to forum[at]nomachinec[dot]com.

    #35220
    manskirtbrew
    Participant

    Emailed, thank you.

    #35327
    kroy
    Contributor

    Possibly that could be some Router software problem. You can try router reset or upgrade firmware. You can also try to manually set up port forwarding. This is an example of how you can open ports on your router model: https://portforward.com/linksys/wrt54gl/

    In your case you can try:

    Application: NX
    Start: 4000 (this is the default NX port)
    End: 4000
    Protocol: Both
    IP Address: 192.168.1.102 (there should be local IP to your machine with nxserver – according to output which you paste it’s IP with 102 ending)
    Enable: yes (just check the box)

    Save settings. Then you should be able to connect there using External IP and choosen 4000 port

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.