Server unusable

Forums / NoMachine for Windows / Server unusable

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #33618
    Aurum
    Participant

    Most of the time when I open a connection to a Linux Mint 20.1 computer on my local network from my Win7 client the screen is out of focus, the wrong resolution and the mouse does not point to where the cursor is. The attached screenshot (NoMachine – wrong.jpg) shows a typical example where the resolution has increased from its 1600 x 900 setting and no longer fits in the window. The mouse is unusable since if you click on it the coordinates are no where near where the cursor is pointing.

    In this example I got very lucky and the next try worked correctly as shown in NoMachine – right.jpg. Usually it takes several tries to get a workable connection and has even taken as many as 27 tries before getting a usable connection.

    My settings are Enable Viewport Mode and 1600 x 900 (NoMachine settings.jpg). Some servers remember the slider 1600 x 900 setting and use it for subsequent sessions. Most do not remember it and default to a resolution that does fit on the screen. For those servers I check the “Use custom resolution” box. (It’s awkward to have to use the arrow to back out of this screen by 3 steps. Please add a done button.)

    I use the free 7.5.2 version. My client is Windows 7 and all my servers are headless Linux Mint 20.1 Cinnamon 4.8.6 computers with 1080 Ti, 2080 Ti or 3080 GPUs with a dummy load plugged in their HDMI port.

    #33635
    Carin
    Participant

    Hi Aurum,

    In order for us to investigate we need you to collect and send us both client and server-side logs.
    Please see the following article for guidance: Collect server and client logs manually

    Can you please send them directly to forum[at]nomachine[dot]com making sure you use the title of the topic in the subject of your email? Thanks!

    #33658
    Aurum
    Participant

    Attached client nxtrace.log and .nx folder.

    Linux server logs next.

    Attachments:
    #33661
    Aurum
    Participant

    Captured several cases of this happening on attempted server connections. Also attached new client log covering these same instances.

    #34026
    Aurum
    Participant

    This problem is getting worse. I spend far more time just connecting, disconnecting, trying again, repeat…than actually doing the work on the server I need to do.

    Also, I’ve had times when I got a usable server screen and started a multi-step process and it switched to the useless unfocused screen mode forcing me to disconnect and repeatedly attempt to connect to finish the work I’d started.

    #34229
    Carin
    Participant

    Hi Aurum,

    Sorry for the delay. In the meantime, we have been trying to reproduce this issue in our labs, but with no success.
    In order to narrow things down, can you try to check the “Disable the client hardware decoding” option in the session menu panel – Display Settings (https://www.nomachine.com/dt10o00156#5.7)? Thanks!

     

    #34354
    Aurum
    Participant

    I’ve never changed anything under the Modify button. I could not find this option on my client where I control my network. I found it on a server and checked the box for “Disable the client hardware decoding.” Every server I checked after that had it checked. Seems odd that changing it on one server changes it on all servers.

    This is the fifth day and I see no improvement. Let me know what to try next as I’ll be glad to do it.

    #34362
    Carin
    Participant

    Hi Aurum,

    I could not find this option on my client where I control my network.

    My bad here, you’re right I had sent you the link from a different version and it looks different. However, this is a client option only.

    So, now we need to make sure that you are able to click on the Modify button that we see in this screenshot you sent us (client side) and that ‘Disable hardware decoding’ is checked. Can you please do this and come back to us with the result? Thanks!