Service starts and stops directly after the start

Forums / NoMachine for Windows / Service starts and stops directly after the start

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #12874
    basd
    Participant

    After the last update, NoMachine stopped working.

    The service won’t start when start from control panel of NoMachine it say’s running and when I switch to another tab and back, it says stopped.

    If i take look ¬†at log file’s I see these messages after the install

    6264 6520 13:44:26 790.665 NXConvertUsernameToSid: ERROR! Failed to retrieve sid.

    6264 6520 13:44:26 790.665 NXConvertUsernameToSid: Error is 1332, ‘Er is geen toewijzing uitgevoerd tussen accountnamen en beveiligings-id’s.

    And after second reboot I see only “Info: Server process running with pid 7976” in nxerror.log

    if look in nxseervice log i see :

    2656 3744 14:03:08 669.566 nxserviceRunNode: ERROR! Can’t set token information.

    2656 3744 14:03:08 669.566 nxserviceRunNode: Error is 1314, ‘Een van de vereiste bevoegdheden is niet aan de client toegekend.

    ‘.

    2656 3744 14:03:08 669.566 NodeStateMachine/NodeStateMachine: ERROR! Terminate function return error: -1.

    2656 3744 14:03:08 669.566 sendToNode: WARNING! No valid handle for session.

    I have no client log because I don’t have a running server log. Who can help me ?

    I have attached the log files

    System info server:

    Windows 10 fully updated .
    32 GB ram
    128 GB SSD systemdrive
    1TB sata disk for data
    Using NoMachine free

     

     

     

     

    Attachments:
    #12887
    Cato
    Contributor

    Hello basd,

    It seems that nxservice64.exe process might be missing some privileges.

    To verify this:

    1. Download and install Process Explorer from:

    https://technet.microsoft.com/en-us/sysinternals/processexplorer.aspx

    2. Start Process Explorer as Administrator.

    3. Right-click on nxservice64.exe process, select Properties, and go to Security tab.

    4. In the lower pane you should now see privileges held by process.
    Please, provide us the list of privileges with Flags Disabled.

    #12918
    basd
    Participant

    SeBackupPrivilege Disabled

    SeCreatePagefilePrivilege Disabled

    SeCreateSymbolicLinkPrivilege Disabled

    SeDebugPrivilege Disabled

    SeIncreaseBasePriorityPrivilege Disabled

    SeIncreaseQuotaPrivilege Disabled

    SeIncreaseWorkingSetPrivilege Disabled

    SeLoadDriverPrivilege Disabled

    SeManageVolumePrivilege Disabled

    SeProfileSingleProcessPrivilege Disabled

    SeRemoteShutdownPrivilege Disabled

    SeRestorePrivilege Disabled

    SeSecurityPrivilege Disabled

    SeShutdownPrivilege Disabled

    SeSystemEnvironmentPrivilege Disabled

    SeSystemProfilePrivilege Disabled

    SeSystemtimePrivilege Disabled

    SeTakeOwnershipPrivilege Disabled

    SeTcbPrivilege Disabled

    SeTimeZonePrivilege Disabled

    SeUndockPrivilege Disabled

     

    #12920
    basd
    Participant

    sorry wrong list ,

    THis the good list:

    SeAssignPrimaryTokenPrivilege Disabled

    SeBackupPrivilege Disabled

    SeIncreaseQuotaPrivilege Disabled

    SeLoadDriverPrivilege  Disabled

    SeManageVolumePrivilege Disabled

    SeRestorePrivilege Disabled

    SeSecurityPrivilege Disabled

    SeShutdownPrivilege Disabled

    SeSystemEnvironmentPrivilege Disabled

    SeSystemtimePrivilege Disabled

    SeTakeOwnershipPrivilege Disabled

    SeUndockPrivilege Disabled

     

    #13013
    markybob
    Participant

    Same problem here after lastest Windows update

    #13709
    Britgirl
    Keymaster

    We kindly request everyone to update to the latest version 5.2.11 and let us know if you continue to have problems.

    #13795
    mhnj7
    Participant

    I’m having this problem and I’m running 5.2.11 It’s a clean install of Windows 10 and NoMachine.

    #13800
    jmartinez
    Participant

    Same issue with Windows 10 and the latest version 5.2.11

    nxserver.log

    2017-02-16 09:50:49 875.525 ¬†5812 NXSERVER WARNING! Process ‘C:\Program Files (x86)\NoMachine\\bin\\nxexec –server –status’ with pid ‘2096/708’ finished with exit code 1 after 0,031 seconds.

    nxservice.log

    2512 3896 19:15:55 726.602 nxserviceExecuteProcess: ERROR! Read failed.

    2512 3896 19:15:55 726.602 nxserviceExecuteProcess: Error is 32, ‘Broken pipe’.

    nxerror.log

    Error: Cannot send request to NXLSA package.

    Error code is : 0.

    Package’s response is : 0xc0000001.

    Error: Cannot execute nxserver process.

    Error code is : 0.

    Error: Server exec failed.

    #13835
    ringram74
    Participant

    I’m running 5.2.11_1 on a fresh Windows 10 Home installation and having the same problem. My logs are attached.

    Attachments:
    #14165
    Cato
    Contributor

    Hello,

    Please, check thread:

    https://www.nomachine.com/forums/topic/nomachine-not-starting

    and verify if you’re experiencing:

    https://www.nomachine.com/TR03O07676

    #14432
    jmartinez
    Participant

    No protected lsass service in my case.

    #14461
    Cato
    Contributor

    Hello jmartinze,

    Please, make sure that you performed system reboot after installation.

    If the problem still persists:

    1. Gather NoMachine logs using this guide: https://www.nomachine.com/DT07M00098.

    2. Check the value of ‘HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa’
    registry key.

    3. Check if ‘nxlsa’ module is loaded correctly using Process Explorer:

    – Download and install package from https://technet.microsoft.com/pl-pl/sysinternals/processexplorer.

    – Start Process Explorer as Administrator.

    – Click on ‘Find’ and ‘Find handle or DLL’. Type ‘nxlsa’ in search box.

    If the module is correctly loaded, search result will show that module belongs to ‘lsass.exe’ process.

    Send logs, value of registry key and result of ‘nxlsa’ query to forum[at]nomachine[dot]com.

    #15528
    Britgirl
    Keymaster

    We have not received any further information from users, but our own investigations have progressed. This and other related issues linked from within will be fixed in version 6.

Viewing 13 posts - 1 through 13 (of 13 total)

This topic was marked as solved, you can't post.