Session log fills up disk

Forums / NoMachine for Linux / Session log fills up disk

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #4636
    moto
    Participant

    Hello,

    After running out of disk space I found that the file /var/NX/nx/.nx/M-{current session}/session was filling up with the following two events which are each logged several times per second. I have tried decreasing the log level, disabling audio in node.cfg and in the client connection, updating PulseAudio, and upgrading to current version of NX, none of which had any effect. I don’t really care about audio working on this client, just don’t want my disk to fill up.

    24210 25024 14:18:50 071.596 AudioIoPulseaudioServerConnection: ERROR! Connection failure.

    24210 25024 14:18:50 071.621 AudioIoPulseaudioServerConnection: WARNING! pa_context_connect failed.

     

    NX Version: nomachine_4.2.27_1_i686.tar.gz

    Linux distro:  3.12-kali1-486 #1 Debian 3.12.6-2kali1 (2014-01-06) i686 GNU/Linux

     

     

     

    #4644
    barpa
    Participant

    We have opened a trouble report to track this issue:

    https://www.nomachine.com/TR09L04536
    NoMachine logs on Linux are filled up with errors
    about Pulse Audio Server

    A fix for this problem will be included in the next update.

    In the meantime you can try to disable sound notifications
    from the Server status GUI -> Server preferences -> Security
    panel.

    #4652
    moto
    Participant

    Thanks barpa! The suggested workaround solved this. Will watch for the next update.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.