Session negotiation failed. User is not an NX user

Forums / General Discussions / Session negotiation failed. User is not an NX user

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #42485
    larsn
    Participant

    Hi,

    without any changes from my side I cannot connect to my remote sever anymore. I get the message:

    “The session negotiation failed.

    Error: User: ‘username’ is not an NX user”

    I have no idea what changed or what even a NX user is. I could not find anything related to that error message in this forum or anywhere else. Does anyone know what this is about?

    My NX server is on a Linux system, my guest system is Windows.

    Thanks!

     

    #42539
    Britgirl
    Participant

    Are you in charge of the server or is someone else? Is it possible that some setting has changed since you last connected? I assume you are using the latest version 8 packages on both Windows and Linux sides. The error looks like that the server has been configured to not allow users who are not NX users.

    Can you check how the following keys are set in server.cfg? Is it set to 0 or 1? 0 is the default setting when you install.

    #
    # Enable or disable NX users DB:
    #
    # 1: Enabled. Only users listed in NX users DB can login to the NX
    #    server.
    #
    # 0: Disabled. All the authenticated users can login.
    #
    # If the NX user DB is disabled, any user providing a valid password
    # from local DB or through SSHD authentication, can connect to the NX
    # system. This is likely to be the default when SSHD authentication
    # with PAM is enabled.
    #
    #EnableUserDB 0

    #42550
    larsn
    Participant

    Hi Britgirl,

    Thanks for the response. I would be the only one that can access the server settings.

    After trying around for a while, I reinstalled NoMachine on the host and it worked.

    Now (in the reinstalled version) EnableUserDB is 0, but that is to be expected. Maybe that was the issue and it is resolved now.

     

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.