Session negotiation has failed

Forums / NoMachine for Linux / Session negotiation has failed

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #27398
    Avatargabriele
    Participant

    This morning after the reboot, I was unable to connect.
    I attach parts of the log files

    node      localhost:4000              yes
    node      virtual-desktops-limit      no
    node      connections-limit           no
    NX> 105 Listsession –status=”disconnected\054connected” –type=”all” –shadowable=”yes”
    NX> 127 Session list of user ‘vdesktop’:

    Display Type             Session ID                       Services  Depth Screensize Status    Session name               Username Platform           Users Create     Node
    ——- —————- ——————————– ——— —– ———- ——— ————————– ——– —————— —– ———- ————–
    0       physical-desktop 68EE720213F470FD3661FAE418BEFFF3 –D–PSAD N/A   N/A        Connected Local display on localhost vdesktop ubuntu 16.04.6 lts 0     1589348130 localhost:4000

    NX> 595 Cannot open the file ‘/usr/NX/var/db/limits/sessions.vdesktop’ for reading: 13, Permission denied.

     

    3958 3958 07:37:08 435,214 ClientDaemonConnector: Starting a new connection to host ‘xx.xx.xx.xx’ on port ‘4000’.
    3958 3958 07:37:08 435,450 Connection: Started connection at 0x.
    3958 3958 07:37:08 440,939 ClientSession: Started session at 0x.
    3958 3988 07:37:08 485,394 ClientUpnp: WARNING! Mapping of port ‘4276’ failed after ‘4020’ ms.
    Info: Connection to 94.177.175.100 port 4000 started at 07:37:08 541,621.
    3958 4016 07:37:10 128,244 ClientSession: A valid certificate for this server was found.
    3958 3988 07:37:12 495,588 ClientUpnp: WARNING! Mapping of port ‘4276’ failed after ‘4010’ ms.
    3958 3958 07:37:15 044,377 ClientSession: Going to query the server for available services.
    3958 3958 07:37:15 232,795 Connection: Connection at 0x failed.
    3958 3958 07:37:15 232,922 ClientSession: Runnable at 0x caused the session at 0x to fail.
    3958 3958 07:37:15 233,016 ClientSession: Failing reason is ‘La negoziazione della sessione è fallita.’.
    Info: Connection to 94.177.175.100 port 4000 closed at 07:37:15 237,333.
    3958 3958 07:37:15 243,224 ClientSession: Stopping session at 0x.

     

    Info: Slave server running with pid 4022.
    3958 3958 07:37:15 251,486 Connection: Stopping connection at 0x2662180.
    3958 3958 07:37:15 251,776 ClientDaemonConnector: Stopping the current connection.

    How can I solve it?

    #27403
    AvatarHaven
    Contributor

    Hello gabriele,
    To solve the problem you should remove the problematic file and execute
    nxserver --list
    It will fix the database.

    Before that please check the current permissions to that file:
    ls -l /usr/NX/var/db/limits/sessions.vdesktop
    and gather the logs:
    nxserver --debug --collect
    Send them to forum[at]nomachine[dot]com making sure to reference your topic.

    #27407
    Avatargabriele
    Participant

    Does not work:
    I emailed you the logs and it also gives me this error:

    ls -l /usr/NX/var/db/limits/sessions.vdesktop

    ls: cannot access ‘/usr/NX/var/db/limits/sessions.vdesktop’: Permission denied

    sudo ls -l /usr/NX/var/db/limits/sessions.vdesktop

    ls: cannot access ‘/usr/NX/var/db/limits/sessions.vdesktop’: No such file or directory

    #27408
    Avatarmatef
    Participant

    Hi Haven,

    I think I might be having the same problem :

    NX> 595 Cannot open the file ‘/usr/NX/var/db/limits/sessions.ray’ for reading: 13, Permission denied.

    But it is not possible to remove the file (tried with sudo rm) and I noticed a lot of folders in /usr/NX/var/db/are unreadable.

    Also nxserver command is unknown on my system.

    Do you have any solution ?

    Kind regards,

    matef

    #27430
    AvatarBritgirl
    Keymaster

    The file didn’t attach, probably because it exceeded the max size allowed. Please send it to forum[at]nomachine[dot]com making sure you insert the title of this topic in the subject and indicate your forum nickname. Thanks!

    #27417
    Avatarsmacktoid
    Participant

    I got the exact same error on my system this morning too. The timing is quite suspicious.

    I think I may have made things worse by creating the file that the server was looking for. Now I get

    NX> 595 NoMachine server exception: no key selected for table: running. (InfoManager::updateKey).

    I’ll raise a separate topic for this.

    #27422
    Avataruser1242
    Participant

    Hi,

    Looks like this issue also affects me.

    When trying to log into a disconnected session I get the error message: “the session negotiation failed”.

    I am trying to connect from Mac OSX to Ubuntu Linux Machine. In my error log I have the following on the last line:

    NX> 595 Cannot open the file ‘/home/[username]/NX/var/db/limits/sessions.[username]’ for reading: 13, Permission denied.

    I suspect it has something to do with a pending / automatic update in the background because I remember a notification on the previous session log in.

    Is there any way to solve this issue remotely?

    Thanks

    #27438
    Avatargabriele
    Participant

    /etc/NX/nxserver --list

    Last login: Wed May 13 15:17:48 2020 from 5.102.0.132
    xxxx@xxxxr:~$ /etc/NX/nxserver –list
    NX> 500 ERROR: Only a user with administrative privileges can use option: list.
    vdesktop@AnnaServer:~$ sudo /etc/NX/nxserver –list
    [sudo] password for vdesktop:
    NX> 127 Available sessions:

     

    I sent you the email with the logs again

    Display Username Remote IP Session ID Node
    ——- ——– ——— ———- —-

    sudo ls -la /usr/NX/var/db/limits/

    total 8
    drwx—— 2 root root 4096 mag 13 07:07 .
    drwxr-xr-x 9 nx   root 4096 mag 13 10:24 ..

     

     

    #27437
    AvatarHaven
    Contributor

    Hello matef and gabriele,
    You should provide a path to nxserver /etc/NX/nxserver --list.
    To remove those files you need sudo rm -f.

    Please check the whole directory:
    sudo ls -la /usr/NX/var/db/limits/

    #27444
    AvatarHaven
    Contributor

    In case the directory is owned by ‘root’, you could fix it by executing the command:
    sudo chown -R nx /usr/NX/var/db/limits.

    #27443
    Avatartsc88
    Participant

    I’m getting the same error. I’m running Ubuntu 19.10.

    Unable to run nxserver, even from the /etc/NX directory.

    sessions.<user> only had the value 1 in the file. Deleting that file made no difference.

    Problem just started this morning.

    I’m wondering if a complete uninstall and reinstall will do the trick. It’s a person server, so I don’t have to worry about other people being inconvenienced.

    #27445
    Avatargabriele
    Participant

    It works. I hope not to disturb you anymore

    #27448
    Avatartsc88
    Participant

    I changed the ownership of the files in /db/limits to be owned by nx and then rebooted the server. It works now. Thanks!

    #27469
    AvatarHaven
    Contributor

    Good to know that executing that command fixed the problem, the logs confirmed that that was the problem.

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.