Setting to enable desktop sharing

Forums / NoMachine for Linux / Setting to enable desktop sharing

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #40131
    jdslavin
    Participant

    Hi,

    I seem to have accidentally turned off desktop sharing on my Linux desktop. I can ssh into it, but when I try to connect via NX I get the message “The session negotiation failed. Error. Cannot connect to the desktop, screen sharing disabled.” (Note: I have been connecting to my desktop this way successfully for a long time.) I looked around under ~/.nx but couldn’t find anything that looked like the correct setting. The connection and session logs are attached. Any help would be appreciated.

    Connecting from Mac, NX version 7.10.1 to Linux NX version 7.9.2

     

    #40146
    Bilbotine
    Keymaster

    Hi jdslavin,

    From a terminal you can check with nxserver –useredit USERNAME –screensharing yes. This applies to a specific user.

    Also, in the server.cfg check that PhysicalDesktopSharing is set to ‘1’. This key applies to the whole server.

    Does this help?

    #40151
    jdslavin
    Participant

    Thank you. The problem was solved before I got this message, but it could be useful in the future. I’m wondering though, is there a way to edit a text file to fix/change that setting?

     

    As a side note, why would I not be allowed to upload my session log and connection log files in a message to this group? It would seem that those are exactly the types of files one should be able to upload.

    #40164
    Bilbotine
    Keymaster

    Hi jdslavin,

    You can modify the global setting in the file – server.cfg .

    The command nxserver --useredit USERNAME --screensharing yes stores this settings in the redis DB, that cannot be modified manually.

    As for uploading files, some types of documents cannot be uploaded because it has been restricted for security reasons. This is why w always recommend to send us logs via email

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.