Shortcuts and double-click

Forums / NoMachine for Mac / Shortcuts and double-click

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #7278
    songjiang
    Participant

    I’m connecting to a Mac (OSX 10.10.3) remotely from Linux (Ubuntu 14.04 LTS), using NoMachine (4.5.0).

    I’m having two basic problems.

    1)  Double-click doesn’t work in the Mac Finder (but it does word elsewhere on the Mac).  I’ve tried messing around with the mouse double-click settings on both the Mac side and the Linux side, but nothing seems to work.  Sometimes triple-clicking seems to get the double-click effect, but it is inconsistent.  I’ve also tried grabbing the mouse from the Mac side, but that doesn’t work.

    2) I’m getting interference on the Linux side when I use the super and/or alt buttons in keyboard shortcuts.  Having looked up this topic on the forum already, I’ve tried grabbing the keyboard from the Mac side, but it works only inconsistently, and I still get interference from the Linux side.  I’ve also tried the Unity Tweak tool, but there is no dash option for that.  Here is specifically what I want to do.  I work in MS Word on my remote computer (the Mac) from the Linux side and want to be able to enter quick editing shortcuts, especially super-a (select all) and alt-space (rotate through the keyboard input methods).

    Any help would be appreciated.  Just to let you know, I’m not all that proficient in Linux.  If you suggest that I download and install something, I’ll need detailed instructions unless the package is configured to install itself automatically.  If you suggest that I enter code into the terminal window, please give me something I can cut and paste.  Thanks!

     

     

    #7285
    graywolf
    Moderator

    Hello <span class=”bbp-author-name”>songjiang</span>

    1)  Double-click doesn’t work in the Mac Finder

    I am not able to find this issue. I can open documents using double-click without problems. As you found this issue only in Finder, I think it is due to some application-specific configuration. I’d take a look of Mouse settings double-click speed.

    2) I’m getting interference on the Linux side when I use the super and/or alt buttons in keyboard shortcuts.

    Hit Ctrl+Alt+0, then chose “Input” and “Grab the keyboard” input. Sometimes this is not enough, but if you switch the display mode to full screen (Ctrl+Alt+0, “Display”, “Fullscreen”) it works more consistently.

    As last resort, remove the Ubuntu keyboard shortcuts affecting your work. Install CompizConfig Settings Manager, launch it and choose to change settings of Ubuntu Unity Plugin. The interesting keys are in the Launcher tab.

     

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.