Sluggish screen redraw performance etc.

Forums / NoMachine for Mac / Sluggish screen redraw performance etc.

This topic contains 9 replies, has 3 voices, and was last updated by Avatar bucu 1 week, 3 days ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #24058
    Avatar
    MickM
    Participant

    I’m running OS X Mojave 10.14.6 and NoMachine 6.8.1 on my mid-2015 MacBook Pro and connecting to a virtual display. The screen redraw performance is really sluggish. If I open up e.g. nedit and scroll through a multi-page document then screen keeps redrawing over and over again with each new redraw showing a little more content in the direction of the scrolling. Similarly, if I open up the CAD software I routinely run on my linux box I’ll also see very laggy performance on screen redraws etc. I have already tried turning the screen quality pretty much all the way down (for some reason the resolution outs pegged at it’s highest level but it’s grayed out so I can’t change that), and I’ve also restarted my Mac but nothing seems to change the slow performance. Any ideas?

    As a side note, these forums are already slow enough that the added burden of waiting for every single post to be moderated just annoyingly adds to the already typically slow response times. Can we please dispense with the moderation – it really doesn’t seem like anybody here is going to post inflammatory or inappropriate stuff.

    #24075
    Avatar
    graywolf
    Moderator

    Would you provide some info about Linux distribution and desktop environemnt (version of Gnome/KDE) and grab a screenshot of panes “Display settings” and “Connection information” from the NoMachine menu?

    #24115
    Avatar
    MickM
    Participant

    The server  side is running Centos 6.9 and the client side is running OS X Mojave 10.14.6. Pictures of the display settings and connection information are attached.

    #24198
    Avatar
    MickM
    Participant

    Thought I’d pass along another observation. If I have a long text file and I scroll through it using my magic mouse by swiping up/down then I believe the swipe action simply transmits a long sequence of e.g. up or down commands to the host. What I see in the window is that each up/down command in that sequence is treated separately i.e. the window receives a down command so the screen contents moves down a little and the full contents redraw. Then it operates on the next down command and another redraw follows etc. etc. A simple swipe can yield a couple minutes of continuous screen redraws where each redraw yields a slightly shifted screen of information. It never used to do that and I’m darned if I can find a way to prevent it. If anybody out there is able to help me I’d really appreciate it! Please!

    #24209
    Avatar
    graywolf
    Moderator

    You run it in single-application, floating window mode.

    Would you try to run it in “virtual desktop” mode, with X11VectorGraphics disabled? Just edit node.cfg on the Linux server to have:

    AgentX11VectorGraphics 0

    Then connect to the server and chose “Create a virtual desktop” rather then “a new custom session”.

    • This reply was modified 3 weeks, 5 days ago by Avatar graywolf. Reason: Corrected value of AgentX11VectorGraphics to "0"
    #24219
    Avatar
    MickM
    Participant

    Thanks for your response graywolf. I didn’t know to mention it earlier, but the primary reason I use NX is because I can display individual linux windows onto my Mac desktop (and manipulate them using Expose etc.). Displaying the linux desktop on my Mac is simply not ever going to be an option for me. The scrolling used to work just fine when my Mac was running Sierra, but ever since I upgraded to Mojave I’ve had this ultra slow scrolling issue through large text files (and also other sluggish redrawing issues). I did try restarting the server with the X11 vector graphics disabled as you suggested (but still using a custom session) and the issue persisted. Still looking for help! 🙁

    #24234
    Avatar
    graywolf
    Moderator

    Hello. The value of AgentX11VectorGraphics is ignored in floating-window mode, so that can’t help in your case.
    Is it possible that Mojave changed something about the mouse events. Would you check Mouse/Trackpad Settings and trying to change something, for example turn “inertia” off? Would you try a mouse with an ordinary wheel, without multi-touch surface?

    #24240
    Avatar
    MickM
    Participant

    So your hint did reveal a dependence on the annoying behavior being exhibited. It turns out I had my mouse tracking speed set to maximum and that did appear to play a role in all this. I’d like to see if you have the same behavior as me. Open up nedit (floating window mode) and make the window big (so that a screen redraw takes a longer time). Copy in about 5-10 pages of text. Here’s where I hope you have a Magic Mouse. To more highlight this problem, set the tracking speed to maximum and now in one action quickly scroll up, down, up, down using long strokes for each swipe and watch the screen redrawing itself. If you see what I see then your screen will be busy redrawing for a while. Now set the tracking speed to something lower and the performance should be much better. That being said, sometimes even at the lower tracking speed I do still see the issue, but just not as often. Again, I don’t recall seeing this issue in OS X Sierra (before upgrading to Mojave).

    #24325
    Avatar
    MickM
    Participant

    Has anybody been able to confirm this behavior?

    #24403
    Avatar
    bucu
    Participant

    We would like to send you a package with a possible fix for slow redraw problem. Please contact us via mail at forum[at]nomachine[dot]com with your linux distro info so we can prepare a proper package for your system.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.