Small updates to screen are missed

Forums / NoMachine for Linux / Small updates to screen are missed

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #32271
    Avatarmikefrom1974
    Participant

    No matter which settings I toggle on / off / change around, NoMachine seems to not care about small updates to a tiny portion of the screen. An example is the terminal caret in terminal / vi / etc. I disabled caret blink for testing and found that if I open a text file in vi and hit up / down, the caret position only updates every 2 lines or so… or if I insert and start typing. This happens to a lesser degree with caret positions in GUI text editors, right-click menus, pretty much anything that doesn’t update a significant portion of the screen.

    In other RDP platforms, I would look for a setting like “disable regional updating” or “refresh full screen” etc. Is there a way to do this in NoMachine?

    Bandwidth is not an issue as I have dedicated gigabit cards in each machine and a single cable between them. No other traffic is on that connection. Server is Debian 10 w/ Gnome, Client is Windows 10. NoMachine version 7.2.3 on both. Connecting to a physical desktop. I have changed to H264 and dropped res to 2650×1440 and messed with every other setting I could think of to no avail.

    #32299
    Avatarfisherman
    Moderator

    If you are using headless server, please check following article https://www.nomachine.com/AR03P00973.

    #32301
    Avatarmikefrom1974
    Participant

    The server is a laptop so should not be headless. That being said, the built-in screen for the laptop is broken. That being said, the laptop is always plugged in to an external HDMI monitor.

    Regardless, I wiped the system and installed Ubuntu 20.04 for comparison, just to see if maybe it was a Debian thing. With Ubuntu installed, NoMachine is running extremely well and is not lagging or losing small cursor changes.

    So, this problem is either:
    1) An issue with the Debian install of the NVidia drivers.
    2) An issue with the laptop main screen being busted and confusing Debian’s X-server into thinking it’s sorta headless.

    Whatever the issue is/was, my problem was resolved by changing to Ubuntu.

    #32305
    Avatarfisherman
    Moderator

    Thanks for the info. I am glad that you solved the problem.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.