Some issue with Keyboard mapping

Forums / NoMachine for Windows / Some issue with Keyboard mapping

Tagged: ,

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #28808
    noluke
    Participant

    Hi everyone,

    I’ve just installed NoMachine on my linux machine (as server) and on my Windows 10 machine (as client). I launched NoMachine on Windows to control my linux machine. It works great, but I have some issue with the keyboard mapping. I set the Italian keyboard on Windows, but it seems that a few characters are mapped wrongly. The “/” character, i.g, is on my “-” instead. Most of the Hold-key characters are messed up.
    Any way to fix this problem?
    Thank you. luke.

    #28827
    Tor
    Contributor

    Hi Luke. Can you run the command setxkbmap -print in a terminal on Linux and let us know the result? Generally such problems are related to the server keyboard layout not matching the physical keyboard you’re using on the client. For example if you’re using an italian keyboard on Windows, select the italian layout on the server so the remote system correctly interprets the pressed keys.

    #28845
    noluke
    Participant

    @Tor

    setxkbmap -print

    xkb_keymap {
    xkb_keycodes  { include “evdev+aliases(qwerty)” };
    xkb_types     { include “complete”      };
    xkb_compat    { include “complete”      };
    xkb_symbols   { include “pc+it+inet(evdev)”     };
    xkb_geometry  { include “pc(pc105)”     };
    };

    Thanks

    #28875
    Tor
    Contributor

    Hi Luke. Can you confirm whether the command setxkbmap -model pc105 -layout it executed in the Linux terminal helps to solve the issue?

    #28878
    noluke
    Participant

    hi Tor,

    Yes, it works.
    Actually, I had found such a “Fcitx configuration” tool in my linux machine which did something similar, but the setup get deleted at every startup…just like your command. I would need now to run it automatically at the startup.
    Thanks

    #28902
    Tor
    Contributor

    Great! We’ve documented this problem here:

    https://www.nomachine.com/TR09Q09412

    It is due to X.org not setting correctly the keyboard options for the XTEST extension device. Let’s try to work around it.
    Create the file .xinitrc in your home directory (if it doesn’t exist already), and add the following lines (remove the first line if it’s not a new file):

    #!/bin/sh
    XTEST_ID=$(xinput list | grep -Eo "Virtual core XTEST keyboard\s*id\=[0-9]{1,2}" | cut -d= -f 2)
    setxkbmap -device $XTEST_ID -model pc105 -layout it

    Run the command chmod +x .xinitrc to set executable permissions and run it to verify that it works as expected. Each time your X session will start, the script will be executed and it’ll set correctly your layout.

    #28901
    noluke
    Participant

    Ok, I fixed the problem by running the application fcitx on the startup. Thanks

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.