Sound has glitches and is out-of-sync with video

Forums / NoMachine Terminal Server Products / Sound has glitches and is out-of-sync with video

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #9177
    Avatarmkrisk
    Participant

    I am doing some tests with NoMachine Workstation evaluation for Linux and a Windows enterprise client. The server is running in a Debian 8 VM (2 vcpus of Intel Xeon E5-2630 @ 2.40Ghz). I am trying to run some videos in Iceweasel + flash (flashplugin-nonfree). No full screen, no high resolution. When running a virtual session some videos are running perfectly fine (e.g., most videos on youtube that I’ve tried, they work fine even in Full HD). But for other videos the sound has small (but very annoying) glitches. E.g., videos from http://www.spiegel.de/sptv/magazin (JW player + Flash). For some other videos the sound has no glitches but there is a small (but noticeable) delay between the sound and the video stream. I’ve tried virtual sessions both in lightweight and in regular mode – basically the same result.

    When connecting to an existing X-session (Physical display), I don’t have any sound glitches but the delays get much worse.

    I’ve tried different settings for pulseaudio without any success.

    Could you advice any way to get an improvement? I do understand that video will have glitches and low fps, but what I am trying to achieve is sound without glitches + sound in sync with video.

    Kind regards

    #9183
    Avatarbarpa
    Participant

    Hi, thanks for the report. The glitches seem to be a PulseAudio problem. You can try these workarounds:

    – exit Iceweasel
    – run PulseAudio tool: pavucontrol
    – start Iceweasel and the videos should be working
    – keep the pavucontrol running

    or if you do not have pavucontrol:

    – exit Iceweasel
    – run PulseAudio tool, parec, in terminal:
    $ parec –latency=20 –format=float32le –rate=25 –channels=1 –channel-map=mono -d nx_audio_null.monitor /dev/null
    – start Iceweasel and the videos should be working
    – keep the parec running

    #9218
    Avatarmkrisk
    Participant

    Thanks a lot! That indeed solved the problem with glitches! And the problem with sound delays seems to be gone if I switch from VP8 to MJPEG.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.