Sound problem under MacOs Catalina

Forums / NoMachine for Mac / Sound problem under MacOs Catalina

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #28927
    Avatarmagaudmac
    Participant

    Dear all,

    I’m trying to connect to MacOsX Catalina 10.15.6 from a Linux Mint 19.3.

    It works… with no sound! Not Fun… Sound is still coming out from the speaker of my Mac.

    When I’m looking at the output options from my Mac, there is no NoMachine option. I made sure that the NxNode is properly set up from the OS by checking the system preferences>security and privacy>privacy>accessibility –> no result…

    Any idea of how to handle this problem?

    Thanks a lot for your input

    Matthieu

    #28969
    Avatarwitek
    Participant

    Hi,

    It seems that nxaudio kernel extension (kext) is not loaded on MacOS Catalina. It is responsible for creating NoMachine audio adapter. You can try to load it manually by following steps below:

    1. Load nxaudio kext using command:

    sudo kextutil -vvv /Library/Extensions/nxaudio.kext

    2. Check if nxaudio is loaded properly:

    kextstat | grep nxau

    Output of the command above should be similar to

    265 0 0xffffff7f83cd6000 0x5000 0x5000 com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476

    3. Restart NoMachine server:

    sudo /etc/NX/nxserver --restart

    4. Run NoMachine session and verify audio.

    If no output is shown in second step, we will need result of kextutil command from point 1. Did you also approved loading NoMachine kernel extensions in the Security&Privacy panel? More information you can find here:

    https://www.nomachine.com/AR01P00962

    #28972
    Avatarmagaudmac
    Participant

    Hi,

    thanks a lot for taking care of my problem.

    I brought the instruction in the terminal and I got a different answer:

    Defaulting to kernel file ‘/System/Library/Kernels/kernel’

    Kext rejected due to system policy: { URL = “file:///Library/StagedExtensions/Library/Extensions/nxaudio.kext/”, ID = “com.nomachine.driver.nxau” }

    Kext rejected due to system policy: { URL = “file:///Library/StagedExtensions/Library/Extensions/nxaudio.kext/”, ID = “com.nomachine.driver.nxau” }

    Diagnostics for /Library/Extensions/nxaudio.kext:

    So I guess that the problem is still there, isn’t it?

    Look forward for the next step. and thanks again!

    Regards

    Magaud

    #28973
    Avatarmagaudmac
    Participant

    Just to make things clear,

    The copied output from the previous post is to the result of the 1st instruction.

    The 2nd one is giving nothing as feedback.

    Matthieu

    #28991
    Avatarmagaudmac
    Participant

    Hi everybody,

    I’m still having the same problem and it is pretty annoying.

    Does anybody have an idea of where I should begin?

    Thanks a lot for your help.

     

    #28997
    Avatarwitek
    Participant

    So I guess that the problem is still there, isn’t it?

    Yes, nxaudio kext cannot be loaded because it is rejected. Without it, audio inside NoMachine session will not work. I suspect that it is related to the article that I mentioned in my previous message (https://www.nomachine.com/AR01P00962).

    To resolve this problem, please run the command sudo kextload /Library/Extensions/nxaudio.kext on your Mac and then access System Preferences -> Security&Privacy -> General panel. Click on the “Allow” button (see attachment) and restart NoMachine server using command:

    sudo /etc/NX/nxserver --restart

    Attachments:
    #29138
    Avatarmagaudmac
    Participant

    It worked!!!

    Sorry for the late reply, and thanks a lot for helping me on that.

    You are really making my day.

    All the best!

    #29171
    AvatarBritgirl
    Keymaster

    Thanks for letting us know 🙂

Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as solved, you can't post.