Sound works on/off on Windows 10 host & remote machine

Forums / NoMachine for Windows / Sound works on/off on Windows 10 host & remote machine

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #28046
    Avatarckcclinton
    Participant

    Hello guys! I have a Windows 10 laptop and a Windows 10 desktop.  The desktop is my host and the laptop is my remote.  I installed everything today and was trying out some of the audio but there’s no audio coming through even when I went through all the playback devices combination on my host and remote.  I want work on my audio projects when i’m away from my studio through Ableton Live.

    What’s interesting was after an couple of hours i decided to try the audio again.  This time I just tested it on a normal MP3 file and played it through Windows Media Player and it worked.  Spotify also worked with my host at “Focusrite” and my remote at “NoMachine Microphone Adapter”.  But as soon as I opened Ableton Live nothing worked again even though within Ableton I selected “Focusrite” as my audio device.  After I quit Ableton neither Spotify nor Windows Media Player worked anymore.

    #28213
    Avatarwitek
    Participant

    Hi,

    We have checked your environment but we did not notice any problem like that using Ableton Live.

    NoMachine audio devices should be only used on the server side so on the client side your default audio output device should be set to headphones, speakers etc.

    On the server side NoMachine application will take default output device and read audio stream from this
    device (to transmit it to the other side). If you want to change default output device, you have to close the session
    and connect again via NoMachine.

    If you are able to hear audio from other application than NoMachine on the client
    side, I suggest to focus on the remote machine.

    1. What version of Ableton Live do you use?

    2. Does audio work always correctly when you are not running Ableton Live?

    3. What is your default sound output device? Can you please attach screenshot
    of Playback tab in Sound panel? Go to Control Panel -> Hardware and Sound -> Sound.

    4. Please check also if your default sound output device is running in the exclusive mode
    and try to disable it.

    https://answers.microsoft.com/en-us/windows/forum/all/disable-exclusion-mode-windows-audio-driver/92c92324-f189-4ae4-ba14-7c5dda7e6183

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.