Sticky functions keys when using DisplayServerExtraOptions

Forums / NoMachine for Mac / Sticky functions keys when using DisplayServerExtraOptions

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #41502
    fbrown
    Participant

    I am using a Mac to remote into another Mac at work. I also been using the DisplayServerExtraOptions  “-oldeventapi 1” tip for a while to fix 2 things:

    • Dragged content is misaligned when dropped, resulting in frustrating usability
    • Function keys are sometimes not registered, resulting in a “v” being typed instead of “cmd+v” being registered

    For the most part, this fixes these annoyances, but at the cost of an other one: Function keys sometimes become sticky. This has the effect of, for example, having the ctrl key released on the client machine, but is registered as pressed on the server machine. In this case, every left click is registered as a right click (ctrl+click on a mac).

    Once it is noticed that the key is stuck, we can just press it to unstick it. Is there a way around this?

     

    Thanks!

    #41688
    fbrown
    Participant

    I’m using MacOS Monterey on both client and server machines, but I noticed this issue when I was back on Catalina. It’s happening regardless of the application being used.

    #41703
    Britgirl
    Participant

    The Fn key being stuck is a system bug that was fixed when we moved to the latest macOS API. For the old API it cannot be fixed unfortunately.

    #41704
    fbrown
    Participant

    The issue is not with the Fn key, it really seems to affect the Ctrl/Cmd keys.  In truth, i rarely use the fn key because I have a fullsize keyboard, so maybe the issue is present but I had not encoutered the issue (yet).

    Maybe the real issue is not the fact that the ctrl/cmd keys get stuck, but that I have to use “-oldeventapi 1” to avoid bug that are present in the “vanilla” version of NoMachine. If these initial issues could be fixed, I wouldn’t need to use the old API.

    #41721
    bucu
    Participant

    The old event API used when setting that key is deprecated and the problem is not on NoMachine’s side so there is little we can do about it.

    We would like to hear more about the problem with dragging you have mentioned in the first post. Would you be intereseted in trying out a custom package with debug enabled (assuming we won’t be able to reproduce that dragging problem in our labs)?

    As for missing modifiers – it sounds like https://kb.nomachine.com/TR09S10357 can you confirm that this is your problem?

    #41746
    fbrown
    Participant

    I would be willing to try the custom package.

    As for the missing modifiers, it does sound like the bug I had. But I have experienced this with other commands than Cmd+V. For instance, Cmd+C would not be registered in the same way and type a “c” instead

    #41962
    Britgirl
    Participant

    Please check your email inbox for mails from me 🙂 It’s a regular dmg package with debug enabled to be installed on the server side. After installing it, reproduce the following issues:

    1) Dragged content is misaligned when dropped, resulting in frustrating usability
    2) Function keys are sometimes not registered, resulting in a “v” being typed instead of “cmd+v” being registered

    Zip up the logs and then send to us. You can just hit reply to the email you receive from me and send them that way. Thanks!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.