Strange key mapping iOS to Mac / Linux German layout

Forums / NoMachine for Mobile / Strange key mapping iOS to Mac / Linux German layout

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #38155
    Georgf
    Participant

    Hi there,
    I really like NoMachine, but I have a strange problem with the key mapping between iOS on iPad Pro. When I access my Mac from my iPad (and also Linux) the mapping of the keys is wrong.

    For example. If I hit the “-” Key, “ß” is send.
    I have German Layout on both Systems (Mac and iPad). It’s the same when I access Ubuntu from my iPad.

    I already disabled “smart punctation” on the iPad.
    Access Ubuntu from my Macbook works as expected.

    Can something give me some tips, how to fix the keyboard on iOS?

    Thx Georg

    #38297
    Britgirl
    Keymaster

    We didn’t reproduce issues on iOS with keyboard layouts, but we did notice that the swapped keys that you reported occurred when the iOS device uses an English layout. You should add a German keyboard in Keyboards system settings, and select the Deutsch layout in the popup opened by tapping the small world icon in the virtual keyboard before starting the connection to the desktop.

    #38337
    Georgf
    Participant

    I triple checked the Layouts. Removed the English layout completly, but still ß and – are wrong. This happens with the virtual and the magic keyboard.

    I am running out of ideas.

    #38340
    Tor
    Contributor

    Hi Georg. We still can’t reproduce your issue on our range of iPad devices, so we could collect a few more information and maybe discover it is an easy configuration problem to solve!

    First of all, can you confirm your iPadOS version, and iPad Pro model?

    We would also like to know the name of the layout used on iPad and on Mac (let’s focus on it for now, we’ll possibly check Linux later). I’ve attached two screenshots from iOS as an example of available keyboard layouts and languages. I’d need to know the correct name of the layout you’re using when you’re connected to the remote desktop. Same thing for Mac, there are multiple German layouts, what is the one selected in the Keyboard configuration?

     

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.