strict client settings

Forums / NoMachine for Windows / strict client settings

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #359
    Avatartsiganenok
    Participant

    Hello,

    I’m using nomachine 4 client on windows which connects to Linux based nomachine terminal server.
    I would like to make the client as strict as possible by disabling as much client configuration options as possible (except autdio).
    Any reference how to get it done ? I did some changes to client config file (nxs), but there are a lot of missing options.
    Anyone maybe have a link to full config file documentation, I wasn’t able to find it.

    btw, is it possible to make microphone unmutted by default? each time I open the client i have to unmute it… annoying 🙁

    #371
    Avatartitan
    Participant

    The fact the user has to explicitly enable the microphone at session startup is a security feature, to avoid that the microphone can be inadvertently left active and so a user sitting at the remote side can hear what you say (with an appropriate program). Presumably you know whether there can be somebody at the remote side, but NoMachine can’t know.

    Di you consider this? Would a dialog showed at session startup improve things? Of course you would be able to select “Don’t show this dialog again” if the dialog annoys you.

    #372
    Avatartsiganenok
    Participant

    the point is that I need to connect a lot of users to same machine, each user should have everything preconfigured without any ability to change settings, the settings window will be disabled, so user will not have any access to it, but he have to use mic.
    isn’t there some option in nxs file like
    <option key=”Audio is muted” value=”false” />
    for microphone ?

    as well, any idea how to disable the nxserver monitor ( the !M icon on panel ) on linux ?

    #373
    Avatarsil04
    Keymaster

    Hi tsiganenok,

    in NoMachine locking down a configuration happens on the server, not on the client. The client will query the server to know which service is available and allowed, based on the server configuration and profile. This offers better security since it is the server that you mainly want to protect.

    There are two ways to lock down a configuration:

    1. Operating at the server level, by changing the server and node configuration. This will apply to all users connecting to that server.

    2. By creating profile rules. This last option is available only with servers tailored for the enterprise and allow to create configurations also on a per-user basis.

    Regarding of point 1, you can find here instructions about how to enable or disable device sharing services:

    http://www.nomachine.com/AR10K00734

    #376
    Avatartitan
    Participant

    Create a .nxs file with your settings, protect the .nxs file so that it cannot modified by the user (using chown/chmod or putting it on a read-only file system), create a link on the client’s desktop. That’s it.

    As I tried to explain, the microphone is handled in a special way. This is intended to protect the user.

    We had a quick meeting and we decided to modify the key as:

    <option key=”Audio is muted” value=”default” />

    In this way the default behavior is preserved but if you change it in the .nxs to true or false it will retain the requested setting. This change should be available in the update published tomorrow.

    #377
    Avatartsiganenok
    Participant

    WOW! I’m shocked ! 🙂
    but will this options include the microphone mute / unmute as well ?
    do you maybe have IRC channel for such things ?

    sil04, thank you for your reply, it was very usefull ! already made required changes 🙂

    #378
    Avatartitan
    Participant

    but will this options include the microphone mute / unmute as well ?

    I copied from your post, but yes I was referring to the microphone ;-).

    #382
    Avatartsiganenok
    Participant

    It’s really GOOD news ! so I can mark one point as done
    We are currently working with nxclient 3.5 and freeNX in production.
    Nomachine 4 provides us with much better audio support, this is the reason we want to upgrade, but we have to set it up in kiosk mode, very strict client.
    I’ve already disabled all possible options like files transfer, disks and network sharing, recording and so on, but another feature I’m missing is to make the client fullscreen without an option to resize or minimize it (I know how to get client running in fullscreen automatically, but the user still have an option to change it).
    As well an option to disable the !M icon ( the monitor as I understand ).

    #390
    Avatarsil04
    Keymaster

    tsiganenok,

    an option to disable the !M icon

    you may find how to do here:

    https://www.nomachine.com/forums/forums/topic/remove-menubar#post-360

    and next post on the same topic:

    https://www.nomachine.com/forums/forums/topic/remove-menubar#post-367

    #391
    Avatartsiganenok
    Participant

    Thanks, I’ve already seen both posts. In both you offer to disable the server which isn’t an option for me because new users should be able to connect anytime …

    as far as I understand the correspond process nxclient.bin with –monitor flag ? is it true ?
    if so, is it possible to run it without the flag ?
    or maybe any option to make this proccess not running at all? once i’m killing it, it is being restarted automatically.

    #428
    Avatartsiganenok
    Participant

    Hi, I see the new version was released, as well the session file was redesigned, so what is the option name to make the microphone un-muted by default ?

    #429
    Avatartsiganenok
    Participant

    I found the option to make the microphone unmuted, but it doesn’t affect anything except the icon in settings. To make the mic working you have to mute it and then unmute again, only then the mic starts working.
    As well I have the sound (output) broken on win xp after installing the new version, on win 7 it does work.
    Version I’m talking about is 4.0.362_1 .

    #629
    AvatarBritgirl
    Keymaster

    tsiganenok, we have opened a Trouble Report on the microphone issue. Use this link to track the problem.

    Enabling microphone by default in the client configuration file may not work
    https://www.nomachine.com/TR11K04007

Viewing 13 posts - 1 through 13 (of 13 total)

This topic was marked as solved, you can't post.