Stuck in login screen (Ubuntu 20.04.04 LTS server)

Forums / NoMachine Terminal Server Products / Stuck in login screen (Ubuntu 20.04.04 LTS server)

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #42017
    acruzpr
    Participant

    Hi,

    Multiple users use this server to connect with virtual displays, and we usually leave the sessions running so we don’t lose the spot on the server since we have a limited number of licenses. I was trying to log in to my ongoing session but couldn’t log in. After I entered my password into the lock screen, it got stuck there, and I never made it to the desktop.  The last time this happened, the only solution was to restart the session.

    Is there any way to solve this problem without restarting my session?

    Client: Win10 ver. 7.10.2 (NoMachine Enterprise Desktop)
    Server: Ubuntu 20.04.4 LTS with GNOME

     

    Thanks

    #42026
    Britgirl
    Participant

    There is a bug we are aware of in Gnome that is documented here: https://forums.nomachine.com/topic/hang-after-password-entered#post-39200

    Can you try the workaround there?

    #42411
    acruzpr
    Participant

    Hi Britgirl,

    Thank you very much. I thought that the workaround was not working in my case because I’m not physically connected to the machine, and when I tried it was asking for the IT password since they are the only ones physically logged into the computer.

    After looking at the documentation, here are the steps that worked for me. I hope that this helps others.

    1. ssh to the machine
    2. loginctl list-sessions
    3. identify the sessions that belong to you
    4.  loginctl unlock-session ####
      1. Try the above command in all your session. Probably there is an easiest way to identify the session that is giving the problems.
      2. The session started with c### in my case.
    5. Verify the nomachine window. Once the right session is found, nomachine will log you in and everything will be working as before.

    Thanks!

    #42414
    Britgirl
    Participant

    To be honest, both of these worked for us:

    unlock-session [ID...] ->   Screen unlock one or more sessions
    unlock-sessions         ->  Screen unlock all current sessions

    Anyway, thanks for following up. You can maybe disable automatic screen lock to avoid this from happening in the future.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.