Support for Catalina?

Forums / NoMachine for Mac / Support for Catalina?

This topic contains 25 replies, has 13 voices, and was last updated by Avatar IanF 21 hours, 32 minutes ago.

Viewing 15 posts - 1 through 15 (of 26 total)
  • Author
    Posts
  • #23905
    Avatar
    saltydog
    Participant

    Just upgraded to Catalina and NoMachine is not working anymore. I can connect from a Mojave server, but the Catalina session has an empty desktop and can’t click anywhere…

    Do you have a fix?

     

    #23907
    Avatar
    ggarcia
    Participant

    I have the same problem.  I get a single window open and I cannot click or type any keyboard key.  The Mac login prompt does not show up.

    Thanks,

    #23915
    Avatar
    kroy
    Contributor

    Hi.

    There are some changes on the newest Mac version which we are still investigating, but in the meantime we can provide a workaround. Please follow these short instructions and you should be able to connect without any problems.

    During installation there should show a system dialog named Accessibility Access (Events). The local user, if administrator, can then add the bash application to the list of apps that may control the Mac. Otherwise the remote user will be able to access the Mac only in view-mode.

    Second step is adding the bash application to the Screen Recording list. System dialog named Screen Recording should show after connection via NoMachine from other host or just start local recording from NoMachine Client monitor icon on the system tray (recording don’t have to be saved).

    #23944
    Avatar
    saltydog
    Participant

    Thank you, kroy. But this has to be done only during installation. How to add bash to those settings once already installed? Bash is not listed in the Applications.

    #23958
    Avatar
    taras
    Participant

    Same problem here. I can’t see my old saved connections in NoMachine client on upgraded macOS Catalina. Also when adding a new connection it’s not possible to add a private key. After selecting path to private key file the filed stays empty.

     

    #23960
    Avatar
    chrisemersonnc
    Participant

    +1. Same here.

    Lost ability to use my MBP via NoMachine after installing Catalina.

    #23971
    Avatar
    Tor
    Contributor

    Same problem here. I can’t see my old saved connections in NoMachine client on upgraded macOS Catalina. Also when adding a new connection it’s not possible to add a private key. After selecting path to private key file the filed stays empty.

    Hi taras. When running on Catalina the client will ask you when it wants to access your Desktop or Documents folders. If you don’t grant that permission you can still do it at a later time: open Settings, Security & Privacy, Privacy group, select Full Disk Access permission, press the ‘+’ button and select NoMachine in the list of applications.

    As for the private key, we’ve found a problem with file browsing and we’re working on it with high priority, I’ll update you soon about the status. In the meanwhile you can edit the NXS file to manually add the private key file path in this field:

    <option key="Private key" value="" />

    #23977
    Avatar
    ggarcia
    Participant

    The good news is that I can connect now to my remote Mac using NoMachine with the workaround.  However, the audio is not working yet.  (The option “enable audio streaming and microphone forwarding” is ON.)

    Thanks,

     

    #23998
    Avatar
    kroy
    Contributor

    There are packages available which fix this issue. Please contact us at forum[at]nomachine[dot]com to get the package. This isn’t full fix for Mac Catalina problems, but it will help add correct Privacy permissions to make NoMachine work on this system. Full fix will follow.

    We strongly recommend uninstalling NoMachine and install the new workaround package. Please follow these short instructions and you should be able to connect without any problems.

    During installation there should show a system dialog named Accessibility Access (Events). The local user, as administrator, can then add the nxnode.bin application to the list of apps that may control the Mac. Otherwise the remote user will be able to access the Mac only in view-mode.

    Second step is adding the NoMachine application to the Screen Recording list. System dialog named Screen Recording should show after connection via NoMachine from other host.

    In the case of update, both questions show up during the first NoMachine connection. However, there could possibly still be issues with ‘Screen Recording’, so a restart of nxserver (sudo /etc/NX/nxserver --restart) mighte be necessary. Connect again to see Screen Recording pop-up.

    #24002
    Avatar
    Britgirl
    Keymaster

    The patched package also fixes the sound issue.

    #24020
    Avatar
    tyl
    Participant

    @kroy: I sent an email to that address because I would like to try the patches as well. Thank you 🙂

    #24027
    Avatar
    tyl
    Participant

    @britgirl @kroy The package fixes it for me! Sound works! 🙂 Thank you so much for sending it.

    #24038
    Avatar
    Britgirl
    Keymaster

    Thanks for letting us know Tyl 🙂

    #24062
    Avatar
    edlv
    Participant

    I also sent email ,but got no answer. Is there any hope to get patched package?

    #24074
    Avatar
    Britgirl
    Keymaster

    You should have received the link from me 🙂 yesterday. I’ll resend to make sure you get it.

Viewing 15 posts - 1 through 15 (of 26 total)

You must be logged in to reply to this topic.