Swapped CapLock and Ctrl issue

Forums / General Discussions / Swapped CapLock and Ctrl issue

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #2983
    Avatariceback
    Participant

    I’m old.  I use the semi-standard keyboard layout with Ctrl and CapsLock swapped.  (There was never a good reason for what the vt220 keyboard did to these!) Anyway, in 4.n (4.1.29 server, 4.1.? client, linux to linux) the client does not fully swap the functionalities.  In 3.5 once one had maximized with Ctrl-Alt-F.  Maximize now doesn’t quite maximize. There’s still a banner left from the client machine, with the remote desktop within. I suspect this is part of the issue.  The key labelled “Caps Lock” now toggle caps lock AND is the control key.  Most frustrating to an emacs user. Any hope of a resolution?

    #3126
    Avatarapm
    Participant

    A similar issue appears here after our last NoMachine client and server update.

    Our VIM’s user use to swap CapsLock and Escape (through xmodmap), and this is not working anymore. As iceback says: The key labelled “Caps Lock” now toggle caps lock AND is the [Escape] key.

    Any idea to solve this problem would be much appreciated.

     

    Our config:

    server: NoMachine Workstation Subscription – Version 4.2.19 (on debian)

    client: 4.2.19

    local and distant window managers: various, loaded with .xsession (i3, herbstluftwm, etc)

    #3256
    Avatariceback
    Participant

    Two updates:

    – Connecting 4.x (x likely 1) client to a 3.5 server (fullscreen via Ctrl-Alt-f) behaves nicely.  Caps and Ctrl properly flipped.

    – I’ve learned how to peel back the corner and enable fullscreen but this does not help with a connection to 4.2 server, same client as above.

    Surprised it’s a server thing!

    Please, please, pretty please

    #3270
    Avatargraywolf
    Moderator

    Could you provide more details about your configuration, like

    – Does the problem arise in connections to physical display or to a virtual desktop?

    – What are the desktop environments in use on client and server (Gnome, KDE, etc)? What are the Linux versions in use?

    – How is the Ctrl/CapsLock configured (xmodmap, Gnome keyboard settings, etc)? Is it done on client or server (or both)?

    #3832
    Avatariceback
    Participant

    Sorry for the delay – I expected email notification of updates to thread.

    I have the freebie version so I’m connecting to the physical display.

    On the desktop of the 4.1 server I’m running Gnome on RHEL 6.5.

    I use System/Preferences/Keyboard/Layouts/Layout Options/Contorl Key Position/Swap Ctrl and Caps Lock.

    Done on both server and client (my laptop at home running Ubuntu 12.4/Gnome.

    Remember: the “Caps Lock” key does function as Ctrl, but on each press it toggles caps lock.  Really annoying.

     

    #3874
    Avatariceback
    Participant

    Just loaded 4.2.25 on two RHEL 6.5 boxes.  Problem still here.

    #3913
    Avatargraywolf
    Moderator

    Thank you. We found out where the problem is. This annoying behavior is related to synchronization of client and server modifiers state. We are going to handle it.

     

    #3942
    Avatariceback
    Participant

    Joy.  Thanks a ton.

Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as closed, you can't post.