Switch user or connect with specified user

Forums / NoMachine for Windows / Switch user or connect with specified user

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #42483
    IanT65
    Participant

    I’m using NoMachine on Windows 11 to connect to my remote Debian desktop.

    I can connect but only as the sudo user that installed NoMachine in Debian, I need to connect as another, non sudo user to access apps and files.

    Switch User does not seem to do anything, is it possible to define the user in the connection settings or switch users?

    #42503
    Britgirl
    Participant

    Check that you have not disabled “system” in the the PhysicalDesktopAccess key in the NoMachine server.cfg on your Debian server.

    # Allow the given type of users to connect to the physical desktop.
    # Set this key to 'all' to allow all kind of users, or to 'none' to
    # completely forbid access to the physical desktop. Otherwise give
    # a comma-separated list of values to indicate which type of users
    # is allowed to connect, order is not relevant. Accepted values are:
    
    #
    # administrator: system and NoMachine administrators.
    #
    # trusted:       NoMachine trusted users for connections to physical
    #                desktop.
    #
    # system:        all unprivileged users who have a valid account to
    #                login.
    #
    # owner:         the owner of the physical desktop.
    #
    # guest:         Guest Desktop Sharing users who login anonymously
    #                without having a system account and system guests
    #                with an account generated on demand on the Linux
    #                host. Guests are never allowed to connect to the
    #                desktop of a cloud server.
    #
    #PhysicalDesktopAccess administrator,trusted,system,guest,owner

    It’s enabled by default when you install NoMachine, but I’m not sure what changes you might have made (or made by others).

    Check that the key includes system users e.g. PhysicalDesktopAccess administrator,trusted,system,guest,owner.

    #42510
    IanT65
    Participant

    Thanks Britgirl,

    No changes have been made to the default server.cfg, I find 3 copies at

    1. /usr/NX/etc/server.cfg
    2. /usr/NX/scripts/etc/localhost/server.cfg
    3. /etc/NX/server/localhost/server.cfg

    The last 2 only contain

    ######################################################################
    #                                                                    #
    #  Copyright (c) 2001, 2022 NoMachine, http://www.nomachine.com.     #
    #                                                                    #
    #  All rights reserved.                                              #
    #                                                                    #
    ######################################################################

    #
    # Specify the path of base directory where the NX software has been
    # installed.
    #

    ServerRoot = “/usr/NX”

    while /usr/NX/etc/server.cfg does have more settings none of the text in your quote exists, especially not `PhysicalDesktopAccess administrator,trusted,system,guest,owner

    Adding
    `PhysicalDesktopAccess administrator,trusted,system,owner
    and restarting the NX server still doesn’t allow user switching nor will it accept my credentials to change server settings while logged in to the desktop.

    [removed] is working so I’ll come back to NoMachine another time.

    #42520
    Britgirl
    Participant

    I’ve no idea what version you are using so I’m assuming you’re using the latest.

    From your original topic what I understood was the non-sudo users couldn’t get access. What appears to be the problem is that you don’t actually have access with authorization. By default NoMachine does not let system users connect without acceptance of the desktop owner. So you must change the following setting:

    You have two options. Either you add your username as a trusted user or change this key:

    #
    # Enable, disable or restrict NX Server requesting authorization to
    # the owner of the physical desktop to allow a different user to
    # connect.
    #
    # administrator: system and NoMachine administrators.
    #
    # trusted:       NoMachine trusted users for connections to physical desktop.
    #
    #
    # system:        all unprivileged users who have a valid account to  login.
    #
    #
    # owner:         the owner of the remote desktop.
    #
    #PhysicalDesktopAccessNoAcceptance administrator,trusted,owner

    to look like this:
    PhysicalDesktopAccessNoAcceptance administrator,trusted,owner,system

    p.s I’d avoid having nx-derivatives installed on the same server with NoMachine.

    Supporting earlier versions of NoMachine and NX
    https://www.nomachine.com/AR07O00933

    #42521
    IanT65
    Participant

    Thank you Britgirl, I’ll try that when I have time.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.