Systemctl nxserver.service

Forums / NoMachine for Linux / Systemctl nxserver.service

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #32793
    Avatardande74
    Participant

    Hi,

    On one of my servers after upgrading to 7.4.1 I cannot connect. Getting the Ooops!

    When I’m looking at the status of nxserver.service I see only the following:

    [userl@server ~]$ systemctl status nxserver.service
    ● nxserver.service - NoMachine Server daemon
         Loaded: loaded (/usr/lib/systemd/system/nxserver.service; enabled; vendor preset: disabled)
         Active: active (running) since Tue 2021-04-06 20:52:25 CEST; 31s ago
       Main PID: 364052 (nxserver.bin)
          Tasks: 20 (limit: 9273)
         Memory: 115.7M
         CGroup: /system.slice/nxserver.service
                 └─364052 /usr/NX/bin/nxserver.bin --daemon

    On another server where I haven’t upgraded yet, running 7.3.2 it looks like this:

    [user@server2 ~]$ systemctl status nxserver.service
    ● nxserver.service - NoMachine Server daemon
         Loaded: loaded (/usr/lib/systemd/system/nxserver.service; enabled; vendor preset: disabled)
         Active: active (running) since Sat 2021-03-20 15:24:55 CET; 2 weeks 3 days ago
       Main PID: 20138 (nxserver.bin)
          Tasks: 141 (limit: 13083)
         Memory: 683.0M
         CGroup: /system.slice/nxserver.service
                 ├─ 20138 /usr/NX/bin/nxserver.bin --daemon
                 ├─ 20164 /usr/NX/bin/nxd
                 ├─ 20188 /usr/NX/bin/nxexec --node --user user--priority realtime --mode 0 --pid 46
                 ├─ 20193 /usr/NX/bin/nxnode.bin
                 ├─ 20215 /usr/NX/bin/nxclient.bin --monitor --pid 1268
                 ├─763365 /usr/NX/bin/nxserver.bin -c /etc/NX/nxserver --login -H 5
                 ├─763396 /usr/NX/bin/nxexec --node --user user--priority realtime --mode 0 --pid 28 -H 5
                 ├─763401 /usr/NX/bin/nxnode.bin -H 5
                 ├─763471 /usr/NX/bin/nxcodec.bin
                 └─763696 /usr/NX/bin/nxplayer.bin

    One thing is that I’m afraid I was out of disk space when upgrading. I tried to uninstall the install again but it didn’t help.

    Any ideas?

    Kind Regards,

    — Daniel

    #32808
    Avatarfisherman
    Moderator

    Based on the command output it looks some of NoMachine service are not running. you can confirm it by running command
    sudo /etc/NX/nxserver --status

    To be able to debug specific problem we would need to collect debug logs. You can enable them by:

    sudo /etc/NX/nxserver --debug --enable all 
    sudo /etc/NX/nxserver --restart

    Reproduce the problem.

    sudo /etc/NX/nxserver --debug --collect 
    sudo /etc/NX/nxserver --debug --disable all

    Please attach logs to your reply here or you can send them to forum[at]nomachine[dot]com making sure to use the topic’s title in the subject.

    #32811
    Avatardande74
    Participant

    systemctl start nxserver.service
    ==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ====
    Authentication is required to start 'nxserver.service'.
    Authenticating as: user
    Password:
    ==== AUTHENTICATION COMPLETE ====

    sudo /etc/NX/nxserver --status
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 162 Disabled service: nxnode.
    NX> 162 Disabled service: nxd.

    sudo /etc/NX/nxserver --status
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 162 Disabled service: nxnode.
    NX> 162 Disabled service: nxd.

    sudo /etc/NX/nxserver --debug --collect
    NX> 900 Procedure to collect logs started.
    NX> 900 Creating log archive.
    NX> 900 Log archive succesfully created.
    NX> 900 Archive is: /usr/NX/var/log/archives/NoMachine-log-2021.04.07-17.52.39.zip
    NX> 900 Procedure to collect logs finished successfully.

    Unfortunately, that folder where empty. But, when I restarted like you suggested..

    $ sudo /etc/NX/nxserver --restart
    NX> 162 Disabled service: nxserver.
    NX> 162 Service: nxnode already disabled.
    NX> 162 Service: nxd already disabled.
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 162 WARNING: Cannot find X servers running on this machine.
    NX> 162 WARNING: A new virtual display will be created on demand.
    NX> 161 Enabled service: nxd.

    ..I can start a session using the client.

    But starting/restarting using systemd makes the nxserver not working.

    $ systemctl status nxserver.service
    ● nxserver.service - NoMachine Server daemon
    Loaded: loaded (/usr/lib/systemd/system/nxserver.service; enabled; vendor preset: disabled)
    Active: active (running) since Wed 2021-04-07 18:11:14 CEST; 1s ago
    Main PID: 516166 (nxserver.bin)
    Tasks: 26 (limit: 9273)
    Memory: 618.1M
    CGroup: /system.slice/nxserver.service
    ├─512911 /usr/lib/geoclue-2.0/demos/agent
    ├─515280 /usr/lib/geoclue-2.0/demos/agent
    └─516166 /usr/NX/bin/nxserver.bin --daemon

    #32853
    Avatarfisherman
    Moderator

    It looks for me from the nxserver –restart command that NoMachine does not detect physical desktop on that host. Can you tell me your OS and Desktop environment you have on that host?

    #32856
    Avatardande74
    Participant

    Manjaro Cinnamon

    uname -a
    Linux host 5.11.6-1-MANJARO

    systemctl get-default
    multi-user.target

    #32870
    Avatarkroy
    Contributor

    Hi,

    We tried the same OS and had no problems neither with the detection of the desktop nor with the start of the nxserver service with systemctl. Maybe as you said installation was broken during the update and your disk was out of space? Please try to uninstall the program (sudo /usr/NX/scripts/setup/nxserver --uninstall && sudo rm -rf /usr/NX /etc/NX) and install again the newest version.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.