Terminal server 7.7.4 with Okta configuration not using our proxy to get to okta

Forums / NoMachine Terminal Server Products / Terminal server 7.7.4 with Okta configuration not using our proxy to get to okta

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #35981
    gjones
    Participant

    Hi,

    I have just installed NoMachine terminal server 7.7.4 with includes the new keys to allow authentication using OKTA.

    The keys are configured and seem to be working.  My problem is that the NoMachine process I believe nxserver.bin needs to get to the internet to reach okta.   We are however behind a proxy server and any communication to the internet needs to go through the proxy but the nxserver.bin process I believe attempts to make the connection does not read the system proxy or have anywhere for me to tell it to use a proxy.

    I set the following errors in nxerror.log :

    782320 782320 15:39:49 081.474 ServerOktaAuth: ERROR! Sending request failed with ‘Error’.

    782320 782320 15:39:49 081.567 ServerOktaAuth: Verbose error: ‘Failed to connect to xxx.oktapreview.com port 443: Connection timed out’.

    Are there any settings that I can configure so that the required NoMachine process can use our proxy server to get to okta.

    Thanks

    #36116
    Carin
    Participant

    Hi gjones,

    If you have an active NoMachine subscription I suggest you open a Support Enquiry from your Customer Area. Thank you!

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.