Terminal Server Console Error

Forums / NoMachine Terminal Server Products / Terminal Server Console Error

This topic contains 2 replies, has 2 voices, and was last updated by Avatar Britgirl 5 months, 1 week ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #22263
    Avatar
    SolersDan
    Participant

    Hello;

    New to NoMachine, and honestly, new to Linux as well.  Windows / Network engineer for 25 years.

    Heinously old Dell PE2950 (can’t kill it) running CentOS 7.6 1810, NoMachine Terminal Server 6.6.8_6, Eval Mode.  Determining if it’s a good fit for a remote Linux shop.

    Followed https://www.nomachine.com/DT04O00139 for installation after installing OS fresh and yum updating to current.  Installed realm to authenticate to my AD.  That part all works.

    Using either the NoMachine application or web interface, I cannot bring up the GUI unless the user I’m logged in as is already logged onto the server’s console.  I receive the error:  “no command is configured on the system to run the default console”.

    If the user which I’m trying to NoMachine in as is already logged into the console, the GUI comes up and life is good.

    I ran tail -f * in /usr/NX/var/log while logging in and don’t see any errors.  It recognizes the user who is attempting to log in, from where they are logging in, and protocol (NX).

    The Google Box didn’t have anything on the error I’m seeing.  Wondering (and it’s most likely) that I’ve missed something.
    TIA,

    Dan

     

     

     

     

    #22269
    Avatar
    SolersDan
    Participant

    Solved –  Gnome and the GUI utilities have to be installed before NM Terminal Server.

    #22280
    Avatar
    Britgirl
    Keymaster

    Hi 🙂

    thanks for letting us know.

    Having a desktop environment already installed is necessary, also when installing on headless machines. Most common Linux desktop environments are Unity 3D, GNOME 3, KDE’s Plasma desktop and lightweight ones such as MATE desktop (a fork of GNOME 2), Xfce and LXDE.

    If you are new to Linux, you might find the following useful:

    https://www.nomachine.com/AR04K00667
    https://www.nomachine.com/AR06N00891

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.