Terminate Session

Forums / General Discussions / Terminate Session

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #6907
    sreilly
    Participant

    Can someone give me the preferred method for terminating a session.

    Under NX 3.5 there was the Terminate option, but under NoMachine Workstation 4.5.0_3 (Running on RedHat 6.6) there appears to only be Disconnect from the server or Exit the Player in the menu.

    If I Logout from the RedHat menu (xfce4) I loose the system tray and most of the windowing but the shells and running applications don’t exit.

    I’ve also tried pkill -9 on my username but this doesn’t always kill all my processes.

    Steve

    #6936
    Bilbotine
    Keymaster

    Hello Steve,

    Logout from virtual session should terminate all the processes opened by this session. Currently we know issues with remaining system processes after terminating. Hopefully the update of systemd (part of your Linux distribution) will fix it.

    We have not been able to reproduce the issue with shells and running applications not exiting during termination in our laboratory.

    Could you please collect the content of /home/<userdir>/.nx and /usr/NX/var/log directories (server side) while reproducing this problem and send it with the list of remaining processes to forum[at]nomachine[dot]com?

    There are several options to terminate virtual sessions:

    – to restore the possibility to decide if a session should be terminated by dialog during disconnecting, set in:  /usr/NX/etc/server.cfg  the key  ConnectPolicy … dialog=1  and restart the server.

    – when you are connected to the server, you have a list of running sessions. You can right-click on a virtual session and select a “Terminate session”.

    – log out from session.

    – terminate a virtual session via terminal by running as root  /usr/NX/bin/nxserver –terminate [<sessionid> | <display> | <username>]

    sessionid and display the number of virtual sessions you can get by running  /usr/NX/bin/nxserver –list

    #6978
    sreilly
    Participant

    Hi Bilbotine,

    I’ve set the dialog to 1 and that seems a better option.

    Thanks for your help.

    Steve

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.