The display is updating contents partially

Forums / NoMachine for Linux / The display is updating contents partially

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #39513
    copoops
    Participant

    Hi,

    I’m experienced a strange problem on NoMachine.

    Some random part of the display fails to update on some changes, there is a rectangular part of the screen stay not updated for seconds,  but when you move the mouse to that region, it’s updated immediately again.

    This usually happens with chrome, when I’m switching tabs, only part of the screen is updated, most of the screen in a rectangular region is unchanged, but if you drag the window it’s suddenly updated.

    Network should be not the problem because I’m operating inside the local network so missing a key frame is unlikely.

    I disabled UDP, changed a few encoding types, disabled hardware decoding but nothing works.

    host machine: Ubuntu 22.04 LTS Gnome inside Proxmox VM,

    CPU: AMD R3950X No GPU

    client machine: Ubuntu 22.04 LTS

    #39555
    kroy
    Contributor

    Hi.

    We couldn’t reproduce such problem. What OS is on client side? Which NoMachine version is installed on both sides? What resolution is on server host? Is this connection to the physical desktop? Is there “Resize remote display” option enabled in the player? Did you change some display options in the player during connection?

    #39625
    copoops
    Participant

    Client OS: Ubuntu 22.04 LTS

    Both the client and the server is running nomachine V7.10.1.

    The server is headless, it doesn’t have a monitor,  in node.cfg I added “DefaultDesktopCommand “env GNOME_SHELL_SESSION_MODE=ubuntu /usr/bin/gnome-session –session=ubuntu”.

    This occurred no matter if “Resize remote display” is enabled or not.

    #39630
    kroy
    Contributor

    We were able to reproduce the problem on Chromium on physical display (on x.org desktop) without NoMachine which means that this is not a bug in NoMachine.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.