The free Linux edition asks for subscription and doesn't start

Forums / NoMachine for Linux / The free Linux edition asks for subscription and doesn't start

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #183
    Simeonof
    Participant

    I’ve tried it on several linux machines, and also tried the previous 4.0 release and the current one (360) and they both do the same thing:

    /etc/init.d/nxserver start
    NX> 614 ERROR: Your subscription doesn’t match the NoMachine server product installed.
    NX> 614 ERROR: Please visit the NoMachine web site at: http://www.nomachine.com/
    NX> 614 ERROR: to acquire a valid subscription.
    NX> 614 ERROR: The NX server can’t perform the requested operation.
    NX> 999 Bye.

    The new client works fine though. Somethng wrong with the installation package? (I’m using the 64-bit rpm)

    #187
    sthones
    Participant

    Hi,

    did you upgrade from a 3.x version? I did that and experienced a similar issue that only went away after manually removing the /usr/NX/ directory and then reinstalling the 4.0 version.
    sthones

    #206
    Simeonof
    Participant

    Actually yes, I did upgrade from 3.x, and thanks – uninstalling it first, then removing the /usr/NX folder and installing again the 4.0 version does the trick. However, when I try to connect via NX protocol to this machine, I get <No available sessions on this server> and when I click on it, I get “The server was unable to make the local display available or access to the local display is disabled.”. Any thoughts? The machine I’m installing it on is a SLES11sp2x64 with GNOME.

    #282
    paai
    Participant

    Same here. After removing the old /usr/NX directory, I get


    NX> 700 ERROR: Cannot change ownership of: /etc/NX/nxserver to: nx:nx.
    NX> 700 Server install completed with warnings.
    NX> 700 Please review the install log for details.
    NX> 700 Install completed with errors at: Sun Oct 27 11:42:02 2013.
    NX> 700 NoMachine was configured to run the following service:
    NX> 700 NX service on port: 4000

    and when I try to login with the 3.5 client, I get nx server unavailable or disabled.

    BUT

    when I again removed the /usr/NX directory and tried to install version 4 again, I got:

    paai@breslau:~/Downloads$ sudo dpkg -i nomachine_4.0.352_1_i386.deb
    (Reading database … 354868 files and directories currently installed.)
    Preparing to replace nomachine 4.0.352-1 (using nomachine_4.0.352_1_i386.deb) …
    dpkg: error processing nomachine_4.0.352_1_i386.deb (–install):
    subprocess new pre-installation script returned error exit status 127
    Errors were encountered while processing:
    nomachine_4.0.352_1_i386.deb

    What now?

    By the way, I am very glad with the free linux NX and have been using it for almost as long as it exists.
    If I did not have to pay for this excellent piece of software, I hope I made up for it by praising it on
    every opportunity.

    Paai

    #915
    Britgirl
    Keymaster

    No available sessions on this server

    You should take a look at the forum topic here: https://www.nomachine.com/forums/forums/topic/how-to-enable-local-display#post-251
    It deals with the same message that Simeonof is getting.

    Paai, you should try the latest version (366) making sure you’ve followed the advice in the other topic I just linked. If you are having problems with the installation still, feel free to open a new topic.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as closed, you can't post.