The session negotiation failed error on Windows

Forums / NoMachine for Windows / The session negotiation failed error on Windows

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #37802

    Hello everyone,

    I apologise beforehand if this topic has been done to death, but I have searched everywhere on this forum and Google, however to no avail.
    Our business’ AutoCAD desktop client (Windows Server 2019 Standard) uses Remote Desktop, but only two simultaneous connections are limited.  Therefore, I would like our employees to switch to NoMachine. All of our business laptops, including this AutoCAD, run on our Windows Domain Controller.

    The error I am experiencing is called The session negotiation failed. Error: Cannot create C:\Windows\user\d whenever I connect from my laptop to the client as a test run.

    I have followed this guide about a user having a similar problem to mine, and I tried the recommended fix with the privileges in the local policies. However, it still does not allow me to access it using my general user account through my laptop.

    It seems to only log in on the admin account (separate user to my general user account), but I would like the entire employee to connect to the machine.

    Greatly appreciated if someone could please assist me, thank you so much.

    Kind regards.



    are there special rules in Active Directory for the user which is trying to connect and can’t? E.g the user needs to change password in the next login? If you send us logs from the NoMachine Windows server host where you are trying to log in, these might help. To do that you need to enable debug, reproduce the problem and zip up the logs. Please send them forum[at]nomachine[dot]com making sure to reference the title’s topic as the subject of your email. Instructions are available here:

    Just to clarify because you mentioned a simultaneous connections, the free version of NoMachine permits one incoming connection. If you want unlimited connections to the desktop (and all users will see the same desktop) you need Enterprise Desktop.


Viewing 2 posts - 1 through 2 (of 2 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.