Three different users at log in

Forums / NoMachine for Linux / Three different users at log in

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #12937
    Avatariceback
    Participant

    When I try to connect, the server’s log file (see excerpt below) rattles off three separate users:

    1. u0138544 (Me, server-side account name)
    2. rob (Me, client-side account name)
    3. u0886896 (Defunct server-side account for departed employ who left before the server had it’s mother board replaced)

    Why the other two attempt and why does this connect never get completed: client spins endlessly.

    • The server (at work – Linux integrity 2.6.32-573.7.1.el6.x86_64 #1 SMP Centos 6.8):
      • [root@integrity etc]# /usr/NX/bin/nxserver –version
      • NoMachine – Version 5.1.54
    • The client (at home – macBookPro)
      • NoMachine – Version 5.1.54

    [root@integrity etc]# tail -f /usr/NX/var/log/nxserver.log

     

    2016-11-20 21:15:59 875.826 13514 NXSERVER User ‘u0138544’ logged in from ‘10.66.66.35’ using authentication method password.

    2016-11-20 21:15:59 885.687 13514 NXSERVER WARNING! Cannot get user info for rob.

    2016-11-20 21:15:59 885.817 13514 NXSERVER WARNING! Error is: 2, ‘No such file or directory’.

    2016-11-20 21:15:59 885.930 13514 NXSERVER WARNING! NXLogin: Cannot retrieve absolute username for user: rob.

    2016-11-20 21:15:59 887.505 13514 NXSERVER WARNING! Cannot get user info for u0886896.

    2016-11-20 21:15:59 887.615 13514 NXSERVER WARNING! Error is: 2, ‘No such file or directory’.

    2016-11-20 21:15:59 887.737 13514 NXSERVER WARNING! NXLogin: Cannot retrieve absolute username for user: u0886896.

    2016-11-20 21:15:59 890.360 13514 NXSERVER WARNING! Cannot get user info for rob.

    2016-11-20 21:15:59 890.462 13514 NXSERVER WARNING! Error is: 2, ‘No such file or directory’.

    2016-11-20 21:15:59 890.552 13514 NXSERVER WARNING! NXLogin: Cannot retrieve absolute username for user: rob.

    2016-11-20 21:15:59 892.076 13514 NXSERVER WARNING! Cannot get user info for u0886896.

    2016-11-20 21:15:59 892.193 13514 NXSERVER WARNING! Error is: 2, ‘No such file or directory’.

    2016-11-20 21:15:59 892.283 13514 NXSERVER WARNING! NXLogin: Cannot retrieve absolute username for user: u0886896.

    2016-11-20 21:16:00 567.623 13539 NXSERVER ERROR! Failed to determine the client IP

    2016-11-20 21:16:00 567.767 13539 NXSERVER ERROR! Variables NX_CONNECTION,SSH_CONNECTION,SSH_CLIENT,SSH2_CLIENT not provided.

    2016-11-20 21:16:00 567.825 13539 NXSERVER ERROR! Please set SSHDCheckIP=1 if you want to refuse the connection.

    2016-11-20 21:16:00 567.898 13539 NXSERVER ERROR! Failed to get remote port. Environment NX_CONNECTION,SSH_CONNECTION,SSH_CLIENT,SSH2_CLIENT not set

    2016-11-20 21:16:00 567.958 13539 NXSERVER ERROR! Failed to get local IP. Remote IP is 0.

    2016-11-20 21:16:00 572.412 13539 NXSERVER ERROR! Wrong process id, received pid 0.

    2016-11-20 21:16:00 572.524 13539 NXSERVER WARNING! Could not get SSHD PID: Process 0 does not have expected name.

    2016-11-20 21:16:00 575.160 13539 NXSERVER ERROR! Cannot save forward server pid. ‘value’ for key sshdPid cannot be null

    2016-11-20 21:16:01 350.483 13539 NXSERVER WARNING! Cannot get user info for rob.

    2016-11-20 21:16:01 350.655 13539 NXSERVER WARNING! Error is: 2, ‘No such file or directory’.

    2016-11-20 21:16:01 350.785 13539 NXSERVER WARNING! NXLogin: Cannot retrieve absolute username for user: rob.

    2016-11-20 21:16:01 352.447 13539 NXSERVER WARNING! Cannot get user info for u0886896.

    2016-11-20 21:16:01 352.608 13539 NXSERVER WARNING! Error is: 2, ‘No such file or directory’.

    2016-11-20 21:16:01 352.737 13539 NXSERVER WARNING! NXLogin: Cannot retrieve absolute username for user: u0886896.

    2016-11-20 21:16:01 675.322 13556 NXNODE   ERROR! Application terminated too early.

    2016-11-20 21:16:01 678.287 13539 NXSERVER ERROR! Sending error message ‘NX> 501 ERROR: Session failed, application terminated prematurely.’

    2016-11-20 21:16:02 491.714 13556 NXNODE   WARNING! nxclient –monitor is not running, sending message aborted.

    2016-11-20 21:16:02 492.131 13556 NXNODE   Previous message repeated 8 times

    2016-11-20 21:16:02 492.192 13556 NXNODE   ERROR! NXClient stopped during connect, skip change status.

    2016-11-20 21:16:02 492.826 13539 NXSERVER ERROR! Node reported monitor failure. Killing attached sessions.

    2016-11-20 21:16:02 504.284 13556 NXNODE   WARNING! Process ‘/usr/bin/pulseaudio –high-priority=no’ with pid ‘13646/13646’ finished with signal 11 after 1,118 seconds.

    2016-11-20 21:16:03 639.904 13072 NXSERVER ERROR! Encryptor context not received.

    2016-11-20 21:16:36 637.741 13514 NXSERVER User ‘u0138544’ from ‘10.66.66.35’ logged out.

    C-c C-c

     

    #12964
    Avatarkroy
    Contributor

    Can you send to output of command: sudo /usr/NX/bin/nxserver –userlist to forum[at]nomachine[dot]com? Please also run debug, restart nxserver (sudo /usr/NX/bin/nxserver –restart), collect logs and send them also that we could verify where is the problem. Instructions about debug and collecting logs you can find there: https://www.nomachine.com/DT07M00098.

    2016-11-20 21:16:01 675.322 13556 NXNODE   ERROR! Application terminated too early.

    If you are able to reproduce this problem – can you send also file .xsession-errors? It’s in home directory. If you still have that log file from that issue, you can send the old one.

     

    #12973
    Avatariceback
    Participant

    sudo /usr/NX/bin/nxserver –userlist
    NX> 149 NX users list

    Username                         Redirected to                  Trusted for       Screen sharing Access
    ——————————– —————————— —————– ————– ——–
    rob                                                                               enabled        enabled
    u0886896                                                                          enabled        enabled
    u0138544                                                                          enabled        enabled
    u0690571                                                                          enabled        enabled
    raja                                                                              enabled        enabled
    u0430776                                                                          enabled        enabled
    u0786386                                                                          enabled        enabled
    u0919127                                                                          enabled        enabled
    u1018864                                                                          enabled        enabled

    As I said u0886896 was a member of the team but has moved on. BTW, that Id had ‘technical difficulties’ and he was issued a new account name “raja”.

    I can/have reproduce the problem over several nxserver –restart calls and will do so again (barring a miracle). Do you want the .xsession from the client or the server?

    #12974
    Avatariceback
    Participant

    Server side .xsession-errors
    integrity:~$ cat ./.xsession-errors
    Warning: Missing charsets in String to FontSet conversion
    XIO: fatal IO error 11 (Resource temporarily unavailable) on X server “:1001”
    after 225 requests (91 known processed) with 0 events remaining.
    xterm: fatal IO error 11 (Resource temporarily unavailable) or KillClient on X server “:1001”
    firefox: Fatal IO error 11 (Resource temporarily unavailable) on X server :1001.
    Client side:
    Script for ibus started at run_im.
    Script for auto started at run_im.
    Script for default started at run_im.
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd main process ended, respawning
    init: at-spi2-registryd respawning too fast, stopped

    FULL LOG from –restart (NOT DEBUG) attached.

    #12975
    Avatariceback
    Participant

    Attaching logs generated with debug level 7. It seems to be in a tight loop.
    (I could not find a client side option to ‘not delete files’)

    #12984
    AvatarBritgirl
    Keymaster

    @iceback submit logs to forum[at]nomachine[dot]com. They probably got rejected because they were too big.

    #12996
    Avatariceback
    Participant

    Sent log by email to forum[at]nomachine[dot]com’ (suitable translated I hope).

    Please confirm.

    #12999
    AvatarBritgirl
    Keymaster

    We got them thanks!  🙂

    #13025
    Avatarkroy
    Contributor

    Hi.

    After enabling debug you need to restart nxserver (sudo /usr/NX/bin/nxserver --restart). After that please reproduce problem tar full log directory (cd /usr/NX/var && sudo tar zcf serverlogs.tar.gz log/) and send file to forum[at]nomachine[dot]com.

    Is it headless machine?

    To get rid of warnings with defunct user accounts, please delete them from NoMachine database:

    (`sudo /usr/NX/bin/nxserver –userdel rob &&
    sudo /usr/NX/bin/nxserver –userdel u0886896 `).

    #13055
    Avatariceback
    Participant

    This machine has a KVM attached so it should not be (and in the past wasn’t) headless. Currently x is not starting and am looking in to that as well.

    /usr/NX/bin/nxserver –restart
    NX> 162 Disabled service: nxserver.
    NX> 162 Disabled service: nxnode.
    NX> 162 Disabled service: nxd.
    NX> 161 Enabled service: nxserver.
    NX> 162 WARNING: Cannot find X servers running on this machine.
    NX> 162 WARNING: A new virtual display will be created on demand.
    NX> 161 Enabled service: nxd.

    #13071
    Avatariceback
    Participant

    The issue has been resolved by fixing the xdm initialization.  I believe that is a remnant issue in what NX is doing in absence of a GUI – claiming it will start an virtual session, then failing to do so – but that’s for another day.

    The heart of the issue is a fault in ‘prefdm’ script:  it does an rpm query for packages which supply a graphical interface, then iterates over the results.   The configuration of the server in question had at some point in the recent past (last OS update?) lost it’s X packages and the query return “no packages found for graphical interface” but the prefdm script never recognized the error and tried to process each of those words as a possible display manager!  And did so repeatedly.

    Re-installing the 500+ packages involved in X did the trick.

    case-sorta-closed

    #13084
    Avatarkroy
    Contributor

    Can you check if there is everything fine from NoMachine side? Problem is still appears?

    #13146
    Avatariceback
    Participant

    Yes, NX successfully connects to server now that X is properly installed.  Perhaps there’s an issue remaining w.r.t. the claim that NX will ‘create a Virtual display on demand’ and doesn’t.  I suspect the bad X installation is the root of that problem too.

Viewing 13 posts - 1 through 13 (of 13 total)

This topic was marked as solved, you can't post.